Improper authentication in GitLab
Priority LOW 31CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-287.
Summary
In all versions of GitLab CE/EE since version 14.1, an improper access control vulnerability allows users with expired password to still access GitLab through git and API through access tokens acquired before password expiration.
Why it matters now
EPSS 0.00989 62nd percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 14.1.7, 14.2.5, 14.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 14.1 to before 14.1.7; 14.2 to before 14.2.5; 14.3 to before 14.3.1 | 14.1.7, 14.2.5, 14.3.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 14.1 to before 14.1.7; 14.2 to before 14.2.5; 14.3 to before 14.3.1 Fixed in 14.1.7, 14.2.5, 14.3.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.1.0 to before 14.1.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.1.0 to before 14.1.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.2.0 to before 14.2.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.2.0 to before 14.2.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:4.3.0:*:*:*:community:*:*:* | 4.3.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:4.3.0:*:*:*:enterprise:*:*:* | 4.3.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.1.0 to before 14.1.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.1.0 to before 14.1.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.2.0 to before 14.2.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.2.0 to before 14.2.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:4.3.0:*:*:*:community:*:*:* Versions 4.3.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:4.3.0:*:*:*:enterprise:*:*:* Versions 4.3.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 14.1.7, 14.2.5, 14.3.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-39872
- 2026-10-03 Alias added: GHSA-v95j-qhvj-8v9x
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2021-39872 · CVE Program
- CVE-2021-39872 · NVD
- FIRST EPSS
- GHSA-v95j-qhvj-8v9x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences