In all versions of GitLab CE/EE since version 12.0, a lower privileged user can import…
Priority LOW 23Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In all versions of GitLab CE/EE since version 12.0, a lower privileged user can import users from projects that they don't have a maintainer role on and disclose email addresses of those users.
Why it matters now
EPSS 0.01228 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed GitLab (GitLab): 14.1.7, 14.2.5, 14.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 12.0 to before 14.1.7; 14.2 to before 14.2.5; 14.3 to before 14.3.1 | 14.1.7, 14.2.5, 14.3.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 12.0 to before 14.1.7; 14.2 to before 14.2.5; 14.3 to before 14.3.1 Fixed in 14.1.7, 14.2.5, 14.3.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 12.0 to before 14.1.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 12.0 to before 14.1.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.2 to before 14.2.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.2 to before 14.2.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:14.3.0:*:*:*:community:*:*:* | 14.3.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:14.3.0:*:*:*:enterprise:*:*:* | 14.3.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 12.0 to before 14.1.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 12.0 to before 14.1.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.2 to before 14.2.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.2 to before 14.2.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:14.3.0:*:*:*:community:*:*:* Versions 14.3.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:14.3.0:*:*:*:enterprise:*:*:* Versions 14.3.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 14.1.7, 14.2.5, 14.3.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-39892
- 2026-10-03 Alias added: GHSA-r8rw-g922-j95j
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2021-39892 · CVE Program
- CVE-2021-39892 · NVD
- FIRST EPSS
- GHSA-r8rw-g922-j95j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences