Incorrect authorization in GitLab
Priority LOW 21CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
Incorrect Authorization in GitLab CE/EE 13.4 or above allows a user with guest membership in a project to modify the severity of an incident.
Why it matters now
EPSS 0.00788 56th percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 14.2.6, 14.3.4, 14.4.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 13.4 to before 14.2.6; 14.3 to before 14.3.4; 14.4 to before 14.4.1 | 14.2.6, 14.3.4, 14.4.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 13.4 to before 14.2.6; 14.3 to before 14.3.4; 14.4 to before 14.4.1 Fixed in 14.2.6, 14.3.4, 14.4.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 13.4.0 to before 14.2.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 13.4.0 to before 14.2.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.3.0 to before 14.3.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.3.0 to before 14.3.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:14.4.0:*:*:*:community:*:*:* | 14.4.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:14.4.0:*:*:*:enterprise:*:*:* | 14.4.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 13.4.0 to before 14.2.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 13.4.0 to before 14.2.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.3.0 to before 14.3.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.3.0 to before 14.3.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:14.4.0:*:*:*:community:*:*:* Versions 14.4.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:14.4.0:*:*:*:enterprise:*:*:* Versions 14.4.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 14.2.6, 14.3.4, 14.4.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-39902
- 2026-10-03 Alias added: GHSA-8f66-6ff4-3fj6
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2021-39902 · CVE Program
- CVE-2021-39902 · NVD
- FIRST EPSS
- GHSA-8f66-6ff4-3fj6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences