Large loop in the PNRP dissector in Wireshark 3.4.0 to 3.4.9 and 3.2.0 to 3.2.17 allows…
Priority LOW 36CWE-834Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Large loop in the PNRP dissector in Wireshark 3.4.0 to 3.4.9 and 3.2.0 to 3.2.17 allows denial of service via packet injection or crafted capture file
Why it matters now
EPSS 0.0161 76th percentileScored 2026-11-07
Fix Fixed Wireshark (Wireshark Foundation): 3.2.18, 3.4.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wireshark Foundation | Wireshark | 3.2.0 to before 3.2.18; 3.4.0 to before 3.4.10 | 3.2.18, 3.4.10 | Patch available | CNA |
- Wireshark VendorWireshark Foundation Affected 3.2.0 to before 3.2.18; 3.4.0 to before 3.4.10 Fixed in 3.2.18, 3.4.10 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wireshark:wireshark:*:*:*:*:*:*:*:* | 3.2.0 – 3.2.17; 3.4.0 – 3.4.9 | Vulnerable | Wireshark Foundation |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:wireshark:wireshark:*:*:*:*:*:*:*:* Versions 3.2.0 – 3.2.17; 3.4.0 – 3.4.9 Vulnerable ·Wireshark Foundation
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · CNA Wireshark (Wireshark Foundation) Fixed in 3.2.18, 3.4.10
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-39923
- 2026-10-03 Alias added: GHSA-v75m-35ph-56m2
References
More Wireshark Foundation Wireshark vulnerabilities
- TI-2026-53718 Heap-based Buffer Overflow in Wireshark CVSS 3.1CRITICAL 9.8
- TI-2026-63612 Heap-based Buffer Overflow in Wireshark CVSS 3.1HIGH 8.8
- TI-2024-16149 A buffer overflow in Wireshark before 4.2.0 allows a remote attacker to cause a denial of… CVSS 3.1HIGH 7.5
- TI-2010-00291 Multiple buffer overflows in the LWRES dissector in Wireshark 0.9.15 through 1.0.10 and… CVSS 2.0HIGH 7.5
- TI-2026-63614 Heap-based Buffer Overflow in Wireshark CVSS 3.1HIGH 8.1
- TI-2014-01823 Buffer overflow in the mpeg_read function in wiretap/mpeg.c in the MPEG parser in… CVSS 2.0HIGH 9.3
Sources
- CVE-2021-39923 · CVE Program
- CVE-2021-39923 · NVD
- FIRST EPSS
- GHSA-v75m-35ph-56m2 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-39923 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences