thinkcmf v5.1.7 has an unauthorized vulnerability.
Priority LOW 30CWE-425Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-425.
Summary
thinkcmf v5.1.7 has an unauthorized vulnerability. The attacker can modify the password of the administrator account with id 1 through the background user management group permissions. The use condition is that the background user management group authority is required.
Why it matters now
EPSS 0.00774 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed thinkcmf/thinkcmf (Packagist): 6.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | thinkcmf/thinkcmf (Packagist) | before 6.0.0 | 6.0.0 | Patch available | GHSA-v25c-8349-v2q3 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- thinkcmf/thinkcmf (Packagist) Vendor— Affected before 6.0.0 Fixed in 6.0.0 Patch available GHSA-v25c-8349-v2q3
Remediation
- Fix · GHSA-v25c-8349-v2q3 thinkcmf/thinkcmf (Packagist) Fixed in 6.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-40616
- 2026-10-03 Alias added: GHSA-v25c-8349-v2q3
References
More Thinkcmf vulnerabilities
- TI-2024-20894 ThinkCMF 6.0.9 is vulnerable to File upload via UeditorController.php. CVSS 3.1CRITICAL 9.8
- TI-2022-19215 ThinkCMF version 6.0.7 is affected by a Cross Site Request Forgery (CSRF) vulnerability… CVSS 3.1HIGH 8.8
- TI-2022-19439 ThinkCMF version 6.0.7 is affected by Stored Cross-Site Scripting (XSS). CVSS 3.1MEDIUM 5.4
- TI-2020-15874 Cross Site Scripting (XSS) vulnerability in UserController.php in ThinkCMF version 5.1.5… CVSS 3.1MEDIUM 5.4
- TI-2020-13886 An issue in ThinkCMF X2.2.2 and below allows attackers to execute arbitrary code via a crafted packet. CVSS 3.1CRITICAL 9.8
- TI-2019-05352 ThinkCMF 5.0.190111 allows remote attackers to execute arbitrary PHP code via the… CVSS 3.0HIGH 8.8
Sources
- CVE-2021-40616 · CVE Program
- CVE-2021-40616 · NVD
- FIRST EPSS
- GHSA-v25c-8349-v2q3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences