Ops CLI Deserialization of Untrusted Data leads to Abritrary Code Execution
Priority MEDIUM 54CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Ops CLI version 2.0.4 (and earlier) is affected by a Deserialization of Untrusted Data vulnerability to achieve arbitrary code execution when the checkout_repo function is called on a maliciously crafted file. An attacker can leverage this to execute arbitrary code on the victim machine.
Why it matters now
EPSS 0.09515 95th percentileScored 2026-11-07
Fix Fixed ops-cli (PyPI): 2.0.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Ops-CLI | up to 2.0.4; up to None | — | No fix listed | CNA |
| — | ops-cli (PyPI) | before 2.0.5 | 2.0.5 | Patch available | GHSA-x23q-4j9j-9cxw |
- Ops-CLI VendorAdobe Affected up to 2.0.4; up to None Fixed in — No fix listed CNA
- ops-cli (PyPI) Vendor— Affected before 2.0.5 Fixed in 2.0.5 Patch available GHSA-x23q-4j9j-9cxw
Remediation
- Fix · GHSA-x23q-4j9j-9cxw ops-cli (PyPI) Fixed in 2.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-40720
- 2026-10-03 Alias added: GHSA-x23q-4j9j-9cxw
References
Sources
- CVE-2021-40720 · CVE Program
- CVE-2021-40720 · NVD
- FIRST EPSS
- GHSA-x23q-4j9j-9cxw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences