Unauthorized access to Credit card form in sylius/paypal-plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure, Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200 and CWE-639.
Summary
sylius/paypal-plugin is a paypal plugin for the Sylius development platform. In affected versions the URL to the payment page done after checkout was created with autoincremented payment id (/pay-with-paypal/{id}) and therefore it was easy to predict. The problem is that the Credit card form has prefilled "credit card holder" field with the Customer's first and last name and hence this can lead to personally identifiable information exposure. Additionally, the mentioned form did not require authentication. The problem has been patched in Sylius/PayPalPlugin 1.2.4 and 1.3.1. If users are unable to update they can override a sylius_paypal_plugin_pay_with_paypal_form route and change its URL parameters to (for example) {orderToken}/{paymentId}, then override the Sylius\PayPalPlugin\Controller\PayWithPayPalFormAction service, to operate on the payment taken from the repository by these 2 values. It would also require usage of custom repository method. Additionally, one could override the @SyliusPayPalPlugin/payWithPaypal.html.twig template, to add contingencies: ['SCA_ALWAYS'] line in hostedFields.submit(...) function call (line 421). It would then have to be handled in the function callback.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Sylius | PayPalPlugin | 1.0.0 to before 1.2.4; 1.3.0 to before 1.3.1 | 1.2.4, 1.3.1 | Patch available | CNA |
| — | sylius/paypal-plugin (Packagist) | 1.0.0 to before 1.2.4 | 1.2.4 | Patch available | GHSA-25fx-mxc2-76g7 |
| — | sylius/paypal-plugin (Packagist) | 1.3.0 to before 1.3.1 | 1.3.1 | Patch available | GHSA-25fx-mxc2-76g7 |
- PayPalPlugin VendorSylius Affected 1.0.0 to before 1.2.4; 1.3.0 to before 1.3.1 Fixed in 1.2.4, 1.3.1 Patch available CNA
- sylius/paypal-plugin (Packagist) Vendor— Affected 1.0.0 to before 1.2.4 Fixed in 1.2.4 Patch available GHSA-25fx-mxc2-76g7
- sylius/paypal-plugin (Packagist) Vendor— Affected 1.3.0 to before 1.3.1 Fixed in 1.3.1 Patch available GHSA-25fx-mxc2-76g7
Remediation
- Fix · CNA PayPalPlugin (Sylius) Fixed in 1.2.4, 1.3.1
- Fix · GHSA-25fx-mxc2-76g7 sylius/paypal-plugin (Packagist) Fixed in 1.2.4 Advisory →
- Fix · GHSA-25fx-mxc2-76g7 sylius/paypal-plugin (Packagist) Fixed in 1.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41120
- 2026-10-03 Alias added: GHSA-25fx-mxc2-76g7
References
Patch 2
Advisory 2
Sources
- CVE-2021-41120 · CVE Program
- CVE-2021-41120 · NVD
- FIRST EPSS
- GHSA-25fx-mxc2-76g7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences