Specification non-compliance in JUMPI
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
The evm crate is a pure Rust implementation of Ethereum Virtual Machine. In `evm` crate `< 0.31.0`, `JUMPI` opcode's condition is checked after the destination validity check. However, according to Geth and OpenEthereum, the condition check should happen before the destination validity check. This is a **high** severity security advisory if you use `evm` crate for Ethereum mainnet. In this case, you should update your library dependency immediately to on or after `0.31.0`. This is a **low** severity security advisory if you use `evm` crate in Frontier or in a standalone blockchain, because there's no security exploit possible with this advisory. It is **not** recommended to update to on or after `0.31.0` until all the normal chain upgrade preparations have been done. If you use Frontier or other `pallet-evm` based Substrate blockchain, please ensure to update your `spec_version` before updating this. For other blockchains, please make sure to follow a hard-fork process before you update this.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| rust-blockchain | evm | before 0.31.0 | 0.31.0 | Patch available | CNA |
| — | evm (crates.io) | before 0.31.0 | 0.31.0 | Patch available | GHSA-pvh2-pj76-4m96 |
- evm Vendorrust-blockchain Affected before 0.31.0 Fixed in 0.31.0 Patch available CNA
- evm (crates.io) Vendor— Affected before 0.31.0 Fixed in 0.31.0 Patch available GHSA-pvh2-pj76-4m96
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:evm_project:evm:*:*:*:*:*:rust:*:* | before 0.31.0 | Vulnerable | rust-blockchain |
- cpe:2.3:a:evm_project:evm:*:*:*:*:*:rust:*:* Versions before 0.31.0 Vulnerable ·rust-blockchain
Remediation
- Fix · CNA evm (rust-blockchain) Fixed in 0.31.0
- Fix · GHSA-pvh2-pj76-4m96 evm (crates.io) Fixed in 0.31.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41153
- 2026-10-03 Alias added: GHSA-pvh2-pj76-4m96
References
More rust-blockchain Evm vulnerabilities
- TI-2024-14354 Erroneous handling of `record_external_operation` error return CVSS 3.1HIGH 7.5
- TI-2022-18729 evm has incorrect is_static parameter for custom stateful precompiles CVSS 3.1HIGH 7.5
- TI-2021-10219 Memory over-allocation in evm crate CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-41153 · CVE Program
- CVE-2021-41153 · NVD
- FIRST EPSS
- GHSA-pvh2-pj76-4m96 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences