Rate-limits not working on instances without configured memory cache backend
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, Nextcloud Server did not implement a database backend for rate-limiting purposes. Any component of Nextcloud using rate-limits (as as `AnonRateThrottle` or `UserRateThrottle`) was thus not rate limited on instances not having a memory cache backend configured. In the case of a default installation, this would notably include the rate-limits on the two factor codes. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5, or 22.2.0. As a workaround, enable a memory cache backend in `config.php`.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nextcloud | security-advisories | before 20.0.13; 21.0.0 to before 21.0.5; before 22.2.0 | 20.0.13, 21.0.5, 22.2.0 | Patch available | CNA |
- security-advisories Vendornextcloud Affected before 20.0.13; 21.0.0 to before 21.0.5; before 22.2.0 Fixed in 20.0.13, 21.0.5, 22.2.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:*:*:*:* | before 20.0.13; 21.0.0 to before 21.0.5; 22.0.0 to before 22.2.0 | Vulnerable | nextcloud |
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:*:*:*:* Versions before 20.0.13; 21.0.0 to before 21.0.5; 22.0.0 to before 22.2.0 Vulnerable ·nextcloud
Remediation
- Fix · CNA security-advisories (nextcloud) Fixed in 20.0.13, 21.0.5, 22.2.0
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41177
References
More Nextcloud Server vulnerabilities
- TI-2023-20855 Users can delete external storage mount points CVSS 3.1HIGH 7.7
- TI-2023-11091 Nextcloud download permissions can be changed by resharer CVSS 3.1HIGH 7.5
- TI-2023-10624 Nextcloud Server vulnerable to SSRF via filter bypass due to lax checking on IPs CVSS 3.1MEDIUM 5.3
- TI-2025-37238 Cross-site scripting in Nextcloud CVSS 3.1MEDIUM 6.4
- TI-2023-11086 nextcloud vulnerable to Uncontrolled Resource Consumption CVSS 3.1MEDIUM 6.5
- TI-2022-18738 Exception logging in Sharepoint app reveals clear-text connection details CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-41177 · CVE Program
- CVE-2021-41177 · NVD
- FIRST EPSS
- CVE-2021-41177 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences