Improper Access Control in jupyterhub-firstuseauthenticator
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
FirstUseAuthenticator is a JupyterHub authenticator that helps new users set their password on their first login to JupyterHub. When JupyterHub is used with FirstUseAuthenticator, a vulnerability in versions prior to 1.0.0 allows unauthorized access to any user's account if `create_users=True` and the username is known or guessed. One may upgrade to version 1.0.0 or apply a patch manually to mitigate the vulnerability. For those who cannot upgrade, there is no complete workaround, but a partial mitigation exists. One can disable user creation with `c.FirstUseAuthenticator.create_users = False`, which will only allow login with fully normalized usernames for already existing users prior to jupyterhub-firstuserauthenticator 1.0.0. If any users have never logged in with their normalized username (i.e. lowercase), they will still be vulnerable until a patch or upgrade occurs.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jupyterhub | firstuseauthenticator | before 1.0.0 | 1.0.0 | Patch available | CNA |
| — | jupyterhub-firstuseauthenticator (PyPI) | before 1.0.0 | 1.0.0 | Patch available | GHSA-5xvc-vgmp-jgc3 |
- firstuseauthenticator Vendorjupyterhub Affected before 1.0.0 Fixed in 1.0.0 Patch available CNA
- jupyterhub-firstuseauthenticator (PyPI) Vendor— Affected before 1.0.0 Fixed in 1.0.0 Patch available GHSA-5xvc-vgmp-jgc3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyterhub:first_use_authenticator:*:*:*:*:*:*:*:* | before 1.0.0 | Vulnerable | jupyterhub |
- cpe:2.3:a:jupyterhub:first_use_authenticator:*:*:*:*:*:*:*:* Versions before 1.0.0 Vulnerable ·jupyterhub
Remediation
- Fix · CNA firstuseauthenticator (jupyterhub) Fixed in 1.0.0
- Fix · GHSA-5xvc-vgmp-jgc3 jupyterhub-firstuseauthenticator (PyPI) Fixed in 1.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41194
- 2026-10-03 Alias added: GHSA-5xvc-vgmp-jgc3
References
Patch 2
Advisory 2
Other 5
- https://github.com/jupyterhub/firstuseauthenticator/pull/38/commits/32b21898fb2b53b1a2e36270de6854ad70e9e9bf
- https://github.com/jupyterhub/firstuseauthenticator/pull/38/commits/9e200d974e0cb85d828a6afedb8ab90a37878f28
- https://github.com/jupyterhub/firstuseauthenticator/commit/953418e2450dbc2d854e332350849533b0ebc7ba
- https://github.com/jupyterhub/firstuseauthenticator
- https://github.com/pypa/advisory-database/tree/main/vulns/jupyterhub-firstuseauthenticator/PYSEC-2021-384.yaml
Sources
- CVE-2021-41194 · CVE Program
- CVE-2021-41194 · NVD
- FIRST EPSS
- GHSA-5xvc-vgmp-jgc3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences