UUPSUpgradeable vulnerability in OpenZeppelin Contracts
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
OpenZeppelin Contracts is a library for smart contract development. In affected versions upgradeable contracts using `UUPSUpgradeable` may be vulnerable to an attack affecting uninitialized implementation contracts. A fix is included in version 4.3.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`. For users unable to upgrade; initialize implementation contracts using `UUPSUpgradeable` by invoking the initializer function (usually called `initialize`). An example is provided [in the forum](https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenZeppelin | openzeppelin-contracts | >= 4.1.0 < 4.3.2 | — | No fix listed | CNA |
| — | @openzeppelin/contracts (npm) | 4.1.0 to before 4.3.2 | 4.3.2 | Patch available | GHSA-5vp3-v4hc-gx76 |
| — | @openzeppelin/contracts-upgradeable (npm) | 4.1.0 to before 4.3.2 | 4.3.2 | Patch available | GHSA-5vp3-v4hc-gx76 |
- openzeppelin-contracts VendorOpenZeppelin Affected >= 4.1.0 < 4.3.2 Fixed in — No fix listed CNA
- @openzeppelin/contracts (npm) Vendor— Affected 4.1.0 to before 4.3.2 Fixed in 4.3.2 Patch available GHSA-5vp3-v4hc-gx76
- @openzeppelin/contracts-upgradeable (npm) Vendor— Affected 4.1.0 to before 4.3.2 Fixed in 4.3.2 Patch available GHSA-5vp3-v4hc-gx76
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openzeppelin:contracts:*:*:*:*:*:node.js:*:* | 4.1.0 to before 4.3.2 | Vulnerable | OpenZeppelin |
- cpe:2.3:a:openzeppelin:contracts:*:*:*:*:*:node.js:*:* Versions 4.1.0 to before 4.3.2 Vulnerable ·OpenZeppelin
Remediation
- Fix · GHSA-5vp3-v4hc-gx76 @openzeppelin/contracts (npm) Fixed in 4.3.2 Advisory →
- Fix · GHSA-5vp3-v4hc-gx76 @openzeppelin/contracts-upgradeable (npm) Fixed in 4.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41264
- 2026-10-03 Alias added: GHSA-5vp3-v4hc-gx76
References
Patch 2
Advisory 2
More OpenZeppelin Contracts vulnerabilities
- TI-2022-13196 OpenZeppelin Contracts for Cairo account cannot process transactions on Goerli CVSS 3.1MEDIUM 6.5
- TI-2021-16554 TimelockController vulnerability in OpenZeppelin Contracts CVSS 3.1CRITICAL 10.0
- TI-2021-16553 TimelockController vulnerability in OpenZeppelin Contracts CVSS 3.1CRITICAL 10.0
- TI-2022-13238 GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts CVSS 3.1HIGH 7.5
- TI-2022-13212 OpenZeppelin Contracts's ERC165Checker may revert instead of returning false CVSS 3.1HIGH 7.5
- TI-2023-14377 GovernorCompatibilityBravo may trim proposal calldata CVSS 3.1HIGH 8.8
Sources
- CVE-2021-41264 · CVE Program
- CVE-2021-41264 · NVD
- FIRST EPSS
- GHSA-5vp3-v4hc-gx76 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences