Read the docs
TI-2021-18106 Aliases CVE-2021-41274GHSA-xm34-v85h-9pg2

Authentication Bypass by CSRF Weakness

Priority MEDIUM 41CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

solidus_auth_devise provides authentication services for the Solidus webstore framework, using the Devise gem. In affected versions solidus_auth_devise is subject to a CSRF vulnerability that allows user account takeover. All applications using any version of the frontend component of `solidus_auth_devise` are affected if `protect_from_forgery` method is both: Executed whether as: A `before_action` callback (the default) or A `prepend_before_action` (option `prepend: true` given) before the `:load_object` hook in `Spree::UserController` (most likely order to find). Configured to use `:null_session` or `:reset_session` strategies (`:null_session` is the default in case the no strategy is given, but `rails --new` generated skeleton use `:exception`). Users should promptly update to `solidus_auth_devise` version `2.5.4`. Users unable to update should if possible, change their strategy to `:exception`. Please see the linked GHSA for more workaround details.

Why it matters now

EPSS 0.00726 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed solidus_auth_devise (solidusio): 2.5.4solidus_auth_devise (RubyGems): 2.5.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
solidusiosolidus_auth_devise1.0.0 to before 2.5.42.5.4Patch availableCNA
—solidus_auth_devise (RubyGems)1.0.0 to before 2.5.42.5.4Patch availableGHSA-xm34-v85h-9pg2
  • solidus_auth_devise Vendorsolidusio Affected 1.0.0 to before 2.5.4 Fixed in 2.5.4 Patch available CNA
  • solidus_auth_devise (RubyGems) Vendor— Affected 1.0.0 to before 2.5.4 Fixed in 2.5.4 Patch available GHSA-xm34-v85h-9pg2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:nebulab:solidus_auth_devise:*:*:*:*:*:ruby:*:*1.0.0 to before 2.5.4Vulnerablesolidusio
  • cpe:2.3:a:nebulab:solidus_auth_devise:*:*:*:*:*:ruby:*:* Versions 1.0.0 to before 2.5.4 Vulnerable ·solidusio

Remediation

  • Fix · CNA solidus_auth_devise (solidusio) Fixed in 2.5.4
  • Fix · GHSA-xm34-v85h-9pg2 solidus_auth_devise (RubyGems) Fixed in 2.5.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-41274
  2. 2026-10-03 Alias added: GHSA-xm34-v85h-9pg2
  3. 2026-10-04 EPSS moved to the 50th–90th percentile

References

Sources