Read the docs
TI-2021-18107 Aliases CVE-2021-41275GHSA-26xx-m4q2-xhq8

Authentication Bypass by CSRF Weakness

Priority MEDIUM 41CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

spree_auth_devise is an open source library which provides authentication and authorization services for use with the Spree storefront framework by using an underlying Devise authentication framework. In affected versions spree_auth_devise is subject to a CSRF vulnerability that allows user account takeover. All applications using any version of the frontend component of spree_auth_devise are affected if protect_from_forgery method is both: Executed whether as: A before_action callback (the default). A prepend_before_action (option prepend: true given) before the :load_object hook in Spree::UserController (most likely order to find). Configured to use :null_session or :reset_session strategies (:null_session is the default in case the no strategy is given, but rails --new generated skeleton use :exception). Users are advised to update their spree_auth_devise gem. For users unable to update it may be possible to change your strategy to :exception. Please see the linked GHSA for more workaround details. ### Impact CSRF vulnerability that allows user account takeover. All applications using any version of the frontend component of `spree_auth_devise` are affected if `protect_from_forgery` method is both: * Executed whether as: * A before_action callback (the default) * A prepend_before_action (option prepend: true given) before the :load_object hook in Spree::UserController (most likely order to find). * Configured to use :null_session or :reset_session strategies (:null_session is the default in case the no strategy is given, but rails --new generated skeleton use :exception). That means that applications that haven't been configured differently from what it's generated with Rails aren't affected. Thanks @waiting-for-dev for reporting and providing a patch �� ### Patches Spree 4.3 users should update to spree_auth_devise 4.4.1 Spree 4.2 users should update to spree_auth_devise 4.2.1 ### Workarounds If possible, change your strategy to :exception: ```ruby class ApplicationController < ActionController::Base protect_from_forgery with: :exception end ``` Add the following to`config/application.rb `to at least run the `:exception` strategy on the affected controller: ```ruby config.after_initialize do Spree::UsersController.protect_from_forgery with: :exception end ``` ### References https://github.com/solidusio/solidus_auth_devise/security/advisories/GHSA-xm34-v85h-9pg2

Why it matters now

EPSS 0.00646 51st percentileScored 2026-11-07
Fix Fixed spree_auth_devise (spree): 4.4.1, 4.2.1, 4.1.1 +1spree_auth_devise (RubyGems): 4.4.1, 4.2.1, 4.1.1 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
spreespree_auth_devise4.3.0 to before 4.4.1; 4.2.0 to before 4.2.1; 4.1.0 to before 4.1.1; before 4.0.14.4.1, 4.2.1, 4.1.1, 4.0.1Patch availableCNA
—spree_auth_devise (RubyGems)4.3.0 to before 4.4.14.4.1Patch availableGHSA-26xx-m4q2-xhq8
—spree_auth_devise (RubyGems)4.2.0 to before 4.2.14.2.1Patch availableGHSA-26xx-m4q2-xhq8
—spree_auth_devise (RubyGems)4.1.0 to before 4.1.14.1.1Patch availableGHSA-26xx-m4q2-xhq8
—spree_auth_devise (RubyGems)before 4.0.14.0.1Patch availableGHSA-26xx-m4q2-xhq8
  • spree_auth_devise Vendorspree Affected 4.3.0 to before 4.4.1; 4.2.0 to before 4.2.1; 4.1.0 to before 4.1.1; before 4.0.1 Fixed in 4.4.1, 4.2.1, 4.1.1, 4.0.1 Patch available CNA
  • spree_auth_devise (RubyGems) Vendor— Affected 4.3.0 to before 4.4.1 Fixed in 4.4.1 Patch available GHSA-26xx-m4q2-xhq8
  • spree_auth_devise (RubyGems) Vendor— Affected 4.2.0 to before 4.2.1 Fixed in 4.2.1 Patch available GHSA-26xx-m4q2-xhq8
  • spree_auth_devise (RubyGems) Vendor— Affected 4.1.0 to before 4.1.1 Fixed in 4.1.1 Patch available GHSA-26xx-m4q2-xhq8
  • spree_auth_devise (RubyGems) Vendor— Affected before 4.0.1 Fixed in 4.0.1 Patch available GHSA-26xx-m4q2-xhq8

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:spreecommerce:spree_auth_devise:*:*:*:*:*:ruby:*:*up to 4.0.1; 4.3.0 to before 4.4.1Vulnerablespree
cpe:2.3:a:spreecommerce:spree_auth_devise:4.1.0:-:*:*:*:ruby:*:*4.1.0Vulnerablespree
cpe:2.3:a:spreecommerce:spree_auth_devise:4.1.0:rc1:*:*:*:ruby:*:*4.1.0 rc1Vulnerablespree
cpe:2.3:a:spreecommerce:spree_auth_devise:4.2.0:*:*:*:*:ruby:*:*4.2.0Vulnerablespree
  • cpe:2.3:a:spreecommerce:spree_auth_devise:*:*:*:*:*:ruby:*:* Versions up to 4.0.1; 4.3.0 to before 4.4.1 Vulnerable ·spree
  • cpe:2.3:a:spreecommerce:spree_auth_devise:4.1.0:-:*:*:*:ruby:*:* Versions 4.1.0 Vulnerable ·spree
  • cpe:2.3:a:spreecommerce:spree_auth_devise:4.1.0:rc1:*:*:*:ruby:*:* Versions 4.1.0 rc1 Vulnerable ·spree
  • cpe:2.3:a:spreecommerce:spree_auth_devise:4.2.0:*:*:*:*:ruby:*:* Versions 4.2.0 Vulnerable ·spree

Remediation

  • Fix · CNA spree_auth_devise (spree) Fixed in 4.4.1, 4.2.1, 4.1.1, 4.0.1
  • Fix · GHSA-26xx-m4q2-xhq8 spree_auth_devise (RubyGems) Fixed in 4.4.1 Advisory →
  • Fix · GHSA-26xx-m4q2-xhq8 spree_auth_devise (RubyGems) Fixed in 4.2.1 Advisory →
  • Fix · GHSA-26xx-m4q2-xhq8 spree_auth_devise (RubyGems) Fixed in 4.1.1 Advisory →
  • Fix · GHSA-26xx-m4q2-xhq8 spree_auth_devise (RubyGems) Fixed in 4.0.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-41275
  2. 2026-10-03 Alias added: GHSA-26xx-m4q2-xhq8
  3. 2026-10-20 EPSS moved to the 50th–90th percentile

References

Sources