Improper authentication in Apache Shiro
Priority HIGH 81CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-287.
Summary
Apache Shiro before 1.8.0, when using Apache Shiro with Spring Boot, a specially crafted HTTP request may cause an authentication bypass. Users should update to Apache Shiro 1.8.0.
Why it matters now
EPSS 0.7613 99th percentileScored 2026-11-07
Fix Partial Apache Shiro (Apache Software Foundation): 1.8.0org.apache.shiro:shiro-core (Maven): 1.8.0Red Hat: 5 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Shiro | Apache Shiro to before 1.8.0 | 1.8.0 | Patch available | CNA |
| — | org.apache.shiro:shiro-core (Maven) | before 1.8.0 | 1.8.0 | Patch available | GHSA-f6jp-j6w3-w9hm |
- Apache Shiro VendorApache Affected Apache Shiro to before 1.8.0 Fixed in 1.8.0 Patch available CNA
- org.apache.shiro:shiro-core (Maven) Vendor— Affected before 1.8.0 Fixed in 1.8.0 Patch available GHSA-f6jp-j6w3-w9hm
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:shiro:*:*:*:*:*:*:*:* | before 1.8.0 | Vulnerable | Apache |
| cpe:2.3:a:oracle:financial_services_crime_and_compliance_management_studio:8.0.8.2.0:*:*:*:*:*:*:* | 8.0.8.2.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:financial_services_crime_and_compliance_management_studio:8.0.8.3.0:*:*:*:*:*:*:* | 8.0.8.3.0 | Vulnerable | Oracle |
- cpe:2.3:a:apache:shiro:*:*:*:*:*:*:*:* Versions before 1.8.0 Vulnerable ·Apache
- cpe:2.3:a:oracle:financial_services_crime_and_compliance_management_studio:8.0.8.2.0:*:*:*:*:*:*:* Versions 8.0.8.2.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:financial_services_crime_and_compliance_management_studio:8.0.8.3.0:*:*:*:*:*:*:* Versions 8.0.8.3.0 Vulnerable ·Oracle
Remediation
- Fix · CNA Apache Shiro (Apache Software Foundation) Fixed in 1.8.0
- Fix · GHSA-f6jp-j6w3-w9hm org.apache.shiro:shiro-core (Maven) Fixed in 1.8.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Fuse 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss A-MQ 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Fuse 6 | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Out of support scope |
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41303
- 2026-10-03 Alias added: GHSA-f6jp-j6w3-w9hm
References
Advisory 3
Other 3
- [shiro-user] 20210929 Re: CVE-2021-41303: Apache Shiro before 1.8.0, when using Apache Shiro with Spring Boot, a specially crafted HTTP request may cause an authentication bypass
- https://lists.apache.org/thread.html/raae98bb934e4bde304465896ea02d9798e257e486d04a42221e2c41b@%3Cuser.shiro.apache.org%3E
- https://security.netapp.com/advisory/ntap-20220609-0001
More Apache Shiro vulnerabilities
- TI-2016-03813 Apache Shiro before 1.2.5, when a cipher key has not been configured for the "remember… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-13272 Improper authentication in Apache Shiro CVSS 3.1CRITICAL 9.8
- TI-2022-14167 Authentication bypass in Apache Shiro CVSS 3.1CRITICAL 9.8
- TI-2020-09649 Improper authentication in Apache Shiro CVSS 3.1CRITICAL 9.8
- TI-2020-10910 Apache Shiro before 1.6.0, when using Apache Shiro, a specially crafted HTTP request may cause an authentication bypass. CVSS 3.1HIGH 7.5
- TI-2020-01881 Improper authentication in Apache Shiro CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-41303 · CVE Program
- CVE-2021-41303 · NVD
- FIRST EPSS
- GHSA-f6jp-j6w3-w9hm · GitHub Advisory Database · CC BY 4.0
- CVE-2021-41303 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences