Cross-site scripting in Atlassian Jira Server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Affected versions of Atlassian Jira Server and Data Center allow anonymous remote attackers to inject arbitrary HTML or JavaScript via a Cross-Site Scripting (XSS) vulnerability in the /secure/admin/ImporterFinishedPage.jspa error message. The affected versions are before version 8.13.12, and from version 8.14.0 before 8.20.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Jira Server | before 8.13.12; 8.14.0 and later; before 8.20.2 | 8.13.12, 8.20.2 | Patch available | CNA |
| Atlassian | Jira Data Center | before 8.13.12; 8.14.0 and later; before 8.20.2 | 8.13.12, 8.20.2 | Patch available | CNA |
- Jira Server VendorAtlassian Affected before 8.13.12; 8.14.0 and later; before 8.20.2 Fixed in 8.13.12, 8.20.2 Patch available CNA
- Jira Data Center VendorAtlassian Affected before 8.13.12; 8.14.0 and later; before 8.20.2 Fixed in 8.13.12, 8.20.2 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:atlassian:data_center:*:*:*:*:*:*:*:* | before 8.13.12 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:jira:*:*:*:*:*:*:*:* | before 8.13.12 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:jira_data_center:*:*:*:*:*:*:*:* | 8.14.0 to before 8.20.2 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:jira_server:*:*:*:*:*:*:*:* | 8.14.0 to before 8.20.2 | Vulnerable | Atlassian |
- cpe:2.3:a:atlassian:data_center:*:*:*:*:*:*:*:* Versions before 8.13.12 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:jira:*:*:*:*:*:*:*:* Versions before 8.13.12 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:jira_data_center:*:*:*:*:*:*:*:* Versions 8.14.0 to before 8.20.2 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:jira_server:*:*:*:*:*:*:*:* Versions 8.14.0 to before 8.20.2 Vulnerable ·Atlassian
Remediation
- Fix · CNA Jira Server (Atlassian) Fixed in 8.13.12, 8.20.2
- Fix · CNA Jira Data Center (Atlassian) Fixed in 8.13.12, 8.20.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-41304
- 2026-10-03 Alias added: GHSA-frf8-q8px-qghm
References
More Atlassian Data Center vulnerabilities
- TI-2020-18587 Incorrect authorization in Atlassian Jira Server CVSS 3.1MEDIUM 5.3
- TI-2020-11107 Information disclosure in Atlassian Jira Server CVSS 3.1MEDIUM 5.3
- TI-2021-16503 Insufficient session expiration in Atlassian Jira Server CVSS 3.1HIGH 7.5
- TI-2017-13320 Code injection in Atlassian Jira Server CVSS 3.1HIGH 8.8
- TI-2020-17687 Path traversal in Atlassian Jira Server CVSS 3.1MEDIUM 5.3
- TI-2021-16512 Affected versions of Atlassian Jira Server and Data Center allow unauthenticated remote… CVSS 3.1HIGH 7.5
Sources
- CVE-2021-41304 · CVE Program
- CVE-2021-41304 · NVD
- FIRST EPSS
- GHSA-frf8-q8px-qghm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences