The Unicorn framework before 0.36.1 for Django allows XSS via a component.
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The Unicorn framework before 0.36.1 for Django allows XSS via a component. NOTE: this issue exists because of an incomplete fix for CVE-2021-42053.
Why it matters now
EPSS 0.00699 53rd percentileScored 2026-11-07
Fix Fixed django-unicorn (PyPI): 0.36.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | django-unicorn (PyPI) | before 0.36.1 | 0.36.1 | Patch available | GHSA-ggmv-6q9p-9gm6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- django-unicorn (PyPI) Vendor— Affected before 0.36.1 Fixed in 0.36.1 Patch available GHSA-ggmv-6q9p-9gm6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:django-unicorn:unicorn:*:*:*:*:*:django:*:* | before 0.36.1 | Vulnerable | Django-unicorn |
- cpe:2.3:a:django-unicorn:unicorn:*:*:*:*:*:django:*:* Versions before 0.36.1 Vulnerable ·Django-unicorn
Remediation
- Fix · GHSA-ggmv-6q9p-9gm6 django-unicorn (PyPI) Fixed in 0.36.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-42134
- 2026-10-03 Alias added: GHSA-ggmv-6q9p-9gm6
References
Patch 2
Advisory 2
More Django-unicorn Unicorn vulnerabilities
- TI-2026-24368 django-unicorn affected by component state manipulation via unvalidated attribute access CVSS 3.1MEDIUM 5.3
- TI-2021-18564 The Unicorn framework through 0.35.3 for Django allows XSS via component.name. CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-42134 · CVE Program
- CVE-2021-42134 · NVD
- FIRST EPSS
- GHSA-ggmv-6q9p-9gm6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences