Duplicate Post WordPress Plugin SQL Injection Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The "Duplicate Post" WordPress plugin up to and including version 1.1.9 is vulnerable to SQL Injection. SQL injection vulnerabilities occur when client supplied data is included within an SQL Query insecurely. SQL Injection can typically be exploited to read, modify and delete SQL table data. In many cases it also possible to exploit features of SQL server to execute system commands and/or access the local file system. This particular vulnerability can be exploited by any authenticated user who has been granted access to use the Duplicate Post plugin. By default, this is limited to Administrators, however the plugin presents the option to permit access to the Editor, Author, Contributor and Subscriber roles.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Copy Delete Posts | Duplicate Post WordPress Plugin | before 1.2.0 | 1.2.0 | Patch available | CNA |
- Duplicate Post WordPress Plugin VendorCopy Delete Posts Affected before 1.2.0 Fixed in 1.2.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:duplicate_post_project:duplicate_post:*:*:*:*:*:wordpress:*:* | up to 1.1.9 | Vulnerable | Duplicate Post Project |
- cpe:2.3:a:duplicate_post_project:duplicate_post:*:*:*:*:*:wordpress:*:* Versions up to 1.1.9 Vulnerable ·Duplicate Post Project
Remediation
- Fix · CNA Duplicate Post WordPress Plugin (Copy Delete Posts) Fixed in 1.2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-43408
- 2026-10-03 Alias added: GHSA-p6r2-qh95-8h4m
References
More Copy Delete Posts vulnerabilities
- TI-2023-00909 Inisev Plugins (Various Versions) - Missing Authorization on handle_installation function CVSS 3.1MEDIUM 6.5
- TI-2023-03692 Inisev Plugins (Various Versions) - Cross-Site Request Forgery on handle_installation function CVSS 3.1MEDIUM 4.3
Sources
- CVE-2021-43408 · CVE Program
- CVE-2021-43408 · NVD
- FIRST EPSS
- GHSA-p6r2-qh95-8h4m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences