Command injection in Dell Unity
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-77.
Summary
Dell EMC Unity, Dell EMC UnityVSA and Dell EMC Unity XT versions prior to 5.1.2.0.5.007 contain an operating system (OS) command injection Vulnerability. A locally authenticated user with high privileges may potentially exploit this vulnerability, leading to the execution of arbitrary OS commands on the Unity underlying OS, with the privileges of the vulnerable application. Exploitation may lead to an elevation of privilege.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Unity | before 5.1.2.0.5.007 | 5.1.2.0.5.007 | Patch available | CNA |
- Unity VendorDell Affected before 5.1.2.0.5.007 Fixed in 5.1.2.0.5.007 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dell:emc_unity_operating_environment:*:*:*:*:*:*:*:* | before 5.1.2.0.5.007 | Vulnerable | Dell |
| cpe:2.3:a:dell:emc_unity_xt_operating_environment:*:*:*:*:*:*:*:* | before 5.1.2.0.5.007 | Vulnerable | Dell |
| cpe:2.3:a:dell:emc_unityvsa_operating_environment:*:*:*:*:*:*:*:* | before 5.1.2.0.5.007 | Vulnerable | Dell |
- cpe:2.3:a:dell:emc_unity_operating_environment:*:*:*:*:*:*:*:* Versions before 5.1.2.0.5.007 Vulnerable ·Dell
- cpe:2.3:a:dell:emc_unity_xt_operating_environment:*:*:*:*:*:*:*:* Versions before 5.1.2.0.5.007 Vulnerable ·Dell
- cpe:2.3:a:dell:emc_unityvsa_operating_environment:*:*:*:*:*:*:*:* Versions before 5.1.2.0.5.007 Vulnerable ·Dell
Remediation
- Fix · CNA Unity (Dell) Fixed in 5.1.2.0.5.007
Timeline
- 2026-10-02 Threatist record created from CVE-2021-43589
- 2026-10-03 Alias added: GHSA-cwww-vcw4-xq3m
References
More Dell Emc Unity Operating Environment vulnerabilities
- TI-2021-14655 OS command injection in Dell VNX2 CVSS 3.1CRITICAL 9.8
- TI-2018-01098 XML external entity injection in Dell EMC Unisphere for VMAX Virtual Appliance, Dell EMC… CVSS 3.0CRITICAL 9.8
- TI-2021-14660 Dell VNX2 OE for File versions 8.1.21.266 and earlier, contain an authentication bypass… CVSS 3.1CRITICAL 9.8
- TI-2021-14656 Path traversal in Dell VNX2 CVSS 3.1CRITICAL 9.1
- TI-2021-14662 OS command injection in Dell VNX Control Station CVSS 3.1HIGH 7.2
- TI-2021-14661 OS command injection in Dell VNX Control Station CVSS 3.1HIGH 7.2
Sources
- CVE-2021-43589 · CVE Program
- CVE-2021-43589 · NVD
- FIRST EPSS
- GHSA-cwww-vcw4-xq3m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences