Doctrine DBAL 3.x before 3.1.4 allows SQL Injection.
Priority MEDIUM 47CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Doctrine DBAL 3.x before 3.1.4 allows SQL Injection. The escaping of offset and length inputs to the generation of a LIMIT clause was not probably cast to an integer, allowing SQL injection to take place if application developers passed unescaped user input to the DBAL QueryBuilder or any other API that ultimately uses the AbstractPlatform::modifyLimitQuery API.
Why it matters now
EPSS 0.02447 84th percentileScored 2026-11-07
Fix Fixed doctrine/dbal (Packagist): 3.1.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | doctrine/dbal (Packagist) | 3.0.0 to before 3.1.4 | 3.1.4 | Patch available | GHSA-r7cj-8hjg-x622 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- doctrine/dbal (Packagist) Vendor— Affected 3.0.0 to before 3.1.4 Fixed in 3.1.4 Patch available GHSA-r7cj-8hjg-x622
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:doctrine-project:database_abstraction_layer:*:*:*:*:*:*:*:* | 3.0.0 to before 3.1.4 | Vulnerable | Doctrine-project |
- cpe:2.3:a:doctrine-project:database_abstraction_layer:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.1.4 Vulnerable ·Doctrine-project
Remediation
- Fix · GHSA-r7cj-8hjg-x622 doctrine/dbal (Packagist) Fixed in 3.1.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-43608
- 2026-10-03 Alias added: GHSA-r7cj-8hjg-x622
References
Advisory 4
Sources
- CVE-2021-43608 · CVE Program
- CVE-2021-43608 · NVD
- FIRST EPSS
- GHSA-r7cj-8hjg-x622 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-43608 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences