SQL injection in jackalope/jackalope-doctrine-dbal
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Jackalope Doctrine-DBAL is an implementation of the PHP Content Repository API (PHPCR) using a relational database to persist data. In affected versions users can provoke SQL injections if they can specify a node name or query. Upgrade to version 1.7.4 to resolve this issue. If that is not possible, you can escape all places where `$property` is used to filter `sv:name` in the class `Jackalope\Transport\DoctrineDBAL\Query\QOMWalker`: `XPath::escape($property)`. Node names and xpaths can contain `"` or `;` according to the JCR specification. The jackalope component that translates the query object model into doctrine dbal queries does not properly escape the names and paths, so that a accordingly crafted node name can lead to an SQL injection. If queries are never done from user input, or if you validate the user input to not contain `;`, you are not affected.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jackalope | jackalope-doctrine-dbal | before 1.7.4 | 1.7.4 | Patch available | CNA |
| — | jackalope/jackalope-doctrine-dbal (Packagist) | before 1.7.4 | 1.7.4 | Patch available | GHSA-ph98-v78f-jqrm |
- jackalope-doctrine-dbal Vendorjackalope Affected before 1.7.4 Fixed in 1.7.4 Patch available CNA
- jackalope/jackalope-doctrine-dbal (Packagist) Vendor— Affected before 1.7.4 Fixed in 1.7.4 Patch available GHSA-ph98-v78f-jqrm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jackalope_doctrine-dbal_project:jackalope_doctrine-dbal:*:*:*:*:*:*:*:* | before 1.7.4 | Vulnerable | Jackalope Doctrine-dbal Project |
- cpe:2.3:a:jackalope_doctrine-dbal_project:jackalope_doctrine-dbal:*:*:*:*:*:*:*:* Versions before 1.7.4 Vulnerable ·Jackalope Doctrine-dbal Project
Remediation
- Fix · CNA jackalope-doctrine-dbal (jackalope) Fixed in 1.7.4
- Fix · GHSA-ph98-v78f-jqrm jackalope/jackalope-doctrine-dbal (Packagist) Fixed in 1.7.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-43822
- 2026-10-03 Alias added: GHSA-ph98-v78f-jqrm
References
Patch 1
Advisory 2
Sources
- CVE-2021-43822 · CVE Program
- CVE-2021-43822 · NVD
- FIRST EPSS
- GHSA-ph98-v78f-jqrm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences