Path traversal in message_bus
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
message_bus is a messaging bus for Ruby processes and web clients. In versions prior to 3.3.7 users who deployed message bus with diagnostics features enabled (default off) are vulnerable to a path traversal bug, which could lead to disclosure of secret information on a machine if an unintended user were to gain access to the diagnostic route. The impact is also greater if there is no proxy for your web application as the number of steps up the directories is not bounded. For deployments which uses a proxy, the impact varies. For example, If a request goes through a proxy like Nginx with `merge_slashes` enabled, the number of steps up the directories that can be read is limited to 3 levels. This issue has been patched in version 3.3.7. Users unable to upgrade should ensure that MessageBus::Diagnostics is disabled.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| discourse | message_bus | before 3.3.7 | 3.3.7 | Patch available | CNA |
| — | message_bus (RubyGems) | before 3.3.7 | 3.3.7 | Patch available | GHSA-xmgj-5fh3-xjmm |
- message_bus Vendordiscourse Affected before 3.3.7 Fixed in 3.3.7 Patch available CNA
- message_bus (RubyGems) Vendor— Affected before 3.3.7 Fixed in 3.3.7 Patch available GHSA-xmgj-5fh3-xjmm
Remediation
- Fix · CNA message_bus (discourse) Fixed in 3.3.7
- Fix · GHSA-xmgj-5fh3-xjmm message_bus (RubyGems) Fixed in 3.3.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-43840
- 2026-10-03 Alias added: GHSA-xmgj-5fh3-xjmm
References
Advisory 2
Sources
- CVE-2021-43840 · CVE Program
- CVE-2021-43840 · NVD
- FIRST EPSS
- GHSA-xmgj-5fh3-xjmm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences