Self XSS on user input
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-80.
Summary
jQuery Terminal Emulator is a plugin for creating command line interpreters in your applications. Versions prior to 2.31.1 contain a low impact and limited cross-site scripting (XSS) vulnerability. The code for XSS payload is always visible, but an attacker can use other techniques to hide the code the victim sees. If the application uses the `execHash` option and executes code from URL, the attacker can use this URL to execute their code. The scope is limited because the javascript attribute used is added to span tag, so no automatic execution like with `onerror` on images is possible. This issue is fixed in version 2.31.1. As a workaround, the user can use formatting that wrap whole user input and its no op. The code for this workaround is available in the GitHub Security Advisory. The fix will only work when user of the library is not using different formatters (e.g. to highlight code in different way).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jcubic | jquery.terminal | before 2.31.1 | 2.31.1 | Patch available | CNA |
| — | jquery.terminal (npm) | before 2.31.1 | 2.31.1 | Patch available | GHSA-x9r5-jxvq-4387 |
- jquery.terminal Vendorjcubic Affected before 2.31.1 Fixed in 2.31.1 Patch available CNA
- jquery.terminal (npm) Vendor— Affected before 2.31.1 Fixed in 2.31.1 Patch available GHSA-x9r5-jxvq-4387
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jquery.terminal_project:jquery.terminal:*:*:*:*:*:*:*:* | before 2.31.1 | Vulnerable | Jquery.terminal Project |
- cpe:2.3:a:jquery.terminal_project:jquery.terminal:*:*:*:*:*:*:*:* Versions before 2.31.1 Vulnerable ·Jquery.terminal Project
Remediation
- Fix · CNA jquery.terminal (jcubic) Fixed in 2.31.1
- Fix · GHSA-x9r5-jxvq-4387 jquery.terminal (npm) Fixed in 2.31.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-43862
- 2026-10-03 Alias added: GHSA-x9r5-jxvq-4387
References
Advisory 3
Sources
- CVE-2021-43862 · CVE Program
- CVE-2021-43862 · NVD
- FIRST EPSS
- GHSA-x9r5-jxvq-4387 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences