The Ignition component before 1.16.15, and 2.0.x before 2.0.6, for Laravel has a "fix…
Priority MEDIUM 46CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
The Ignition component before 1.16.15, and 2.0.x before 2.0.6, for Laravel has a "fix variable names" feature that can lead to incorrect access control.
Why it matters now
EPSS 0.01725 77th percentileScored 2026-11-07
Fix Fixed facade/ignition (Packagist): 1.16.15, 2.0.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | facade/ignition (Packagist) | before 1.16.15 | 1.16.15 | Patch available | GHSA-vhrp-8qx4-vr6c |
| — | facade/ignition (Packagist) | 2.0.0 to before 2.0.6 | 2.0.6 | Patch available | GHSA-vhrp-8qx4-vr6c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- facade/ignition (Packagist) Vendor— Affected before 1.16.15 Fixed in 1.16.15 Patch available GHSA-vhrp-8qx4-vr6c
- facade/ignition (Packagist) Vendor— Affected 2.0.0 to before 2.0.6 Fixed in 2.0.6 Patch available GHSA-vhrp-8qx4-vr6c
Remediation
- Fix · GHSA-vhrp-8qx4-vr6c facade/ignition (Packagist) Fixed in 1.16.15 Advisory →
- Fix · GHSA-vhrp-8qx4-vr6c facade/ignition (Packagist) Fixed in 2.0.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-43996
- 2026-10-03 Alias added: GHSA-vhrp-8qx4-vr6c
References
More Facade Ignition vulnerabilities
- TI-2021-02221 Ignition before 2.5.2, as used in Laravel and other products, allows unauthenticated… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10887 The Ignition component before 2.0.5 for Laravel mishandles globals, _get, _post, _cookie… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-43996 · CVE Program
- CVE-2021-43996 · NVD
- FIRST EPSS
- GHSA-vhrp-8qx4-vr6c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences