Information disclosure in ExpressionEngine
Priority LOW 30CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-200.
Summary
Insufficient user input filtering leads to arbitrary file read by non-authenticated attacker, which results in sensitive information disclosure.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00563 47th percentileScored 2026-11-07
Fix Fixed ExpressionEngine (ExpressionEngine): 6.0.3, 6.0.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ExpressionEngine | ExpressionEngine | 6.0.3 to before 6.0.3 | 6.0.3, 6.0.0 | Patch available | CNA |
- ExpressionEngine VendorExpressionEngine Affected 6.0.3 to before 6.0.3 Fixed in 6.0.3, 6.0.0 Patch available CNA
CPE names CISA-ADP · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:expressionengine:expressionengine:6.0.3:*:*:*:*:*:*:* | 6.0.3 | — | ExpressionEngine |
| cpe:2.3:a:expressionengine:expressionengine:6.0.0:*:*:*:*:*:*:* | 6.0.0 | — | ExpressionEngine |
- cpe:2.3:a:expressionengine:expressionengine:6.0.3:*:*:*:*:*:*:* Versions 6.0.3 — ·ExpressionEngine
- cpe:2.3:a:expressionengine:expressionengine:6.0.0:*:*:*:*:*:*:* Versions 6.0.0 — ·ExpressionEngine
Remediation
- Fix · CNA ExpressionEngine (ExpressionEngine) Fixed in 6.0.3, 6.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-44534
- 2026-10-03 Alias added: GHSA-2rm2-mwc8-f72w
References
More ExpressionEngine vulnerabilities
- TI-2021-12747 In Expression Engine before 6.0.3, addonIcon in Addons/file/mod.file.php relies on the… CVSS 3.1CRITICAL 9.8
- TI-2020-10544 ExpressionEngine before 5.3.2 allows remote attackers to upload and execute arbitrary… CVSS 3.1HIGH 8.8
- TI-2021-08771 ExpressionEngine before 5.4.2 and 6.x before 6.0.3 allows PHP Code Injection by certain… CVSS 3.1HIGH 8.8
- TI-2023-09084 In ExpressionEngine before 7.2.6, remote code execution can be achieved by an authenticated Control Panel user. CVSS 3.1HIGH 8.8
- TI-2017-00845 ExpressionEngine version 2.x < 2.11.8 and version 3.x < 3.5.5 create an object signing… CVSS 3.0HIGH 7.5
- TI-2020-06660 SQL injection in ExpressionEngine CVSS 3.1HIGH 7.2
Sources
- CVE-2021-44534 · CVE Program
- CVE-2021-44534 · NVD
- FIRST EPSS
- GHSA-2rm2-mwc8-f72w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences