An issue was discovered in Cobbler before 3.3.1.
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
An issue was discovered in Cobbler before 3.3.1. Files in /etc/cobbler are world readable. Two of those files contain some sensitive information that can be exposed to a local user who has non-privileged access to the server. The users.digest file contains the sha2-512 digest of users in a Cobbler local installation. In the case of an easy-to-guess password, it's trivial to obtain the plaintext string. The settings.yaml file contains secrets such as the hashed default password.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cobbler (PyPI) | before 3.3.1 | 3.3.1 | Patch available | GHSA-5946-mpw5-pqxx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cobbler (PyPI) Vendor— Affected before 3.3.1 Fixed in 3.3.1 Patch available GHSA-5946-mpw5-pqxx
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cobbler_project:cobbler:*:*:*:*:*:*:*:* | before 3.3.1 | Vulnerable | The Cobbler Project |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
- cpe:2.3:a:cobbler_project:cobbler:*:*:*:*:*:*:*:* Versions before 3.3.1 Vulnerable ·The Cobbler Project
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-5946-mpw5-pqxx cobbler (PyPI) Fixed in 3.3.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-45083
- 2026-10-03 Alias added: GHSA-5946-mpw5-pqxx
References
Advisory 7
Other 8
- https://github.com/cobbler/cobbler/pull/2945
- https://github.com/cobbler/cobbler/commit/10b2112db83fedfc391e900edfedc2b4e507d3f7
- https://github.com/cobbler/cobbler
- https://github.com/cobbler/cobbler/releases/tag/v3.3.1
- https://github.com/pypa/advisory-database/tree/main/vulns/cobbler/PYSEC-2022-38.yaml
- https://lists.fedoraproject.org/archives/list/[email protected]/message/TEJN7CPW6YCHBFQPFZKGA6AVA6T5NPIW
- https://lists.fedoraproject.org/archives/list/[email protected]/message/Z5CSXQE7Q4TVDQJKFYBO4XDH3BZ7BLAR
- https://lists.fedoraproject.org/archives/list/[email protected]/message/ZCXMOUW4DH4DYWIJN44SMSU6R3CZDZBE
Sources
- CVE-2021-45083 · CVE Program
- CVE-2021-45083 · NVD
- FIRST EPSS
- GHSA-5946-mpw5-pqxx · GitHub Advisory Database · CC BY 4.0
- CVE-2021-45083 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences