An issue was discovered in Django 2.2 before 2.2.26, 3.2 before 3.2.11, and 4.0 before…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 fixed, 11 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
An issue was discovered in Django 2.2 before 2.2.26, 3.2 before 3.2.11, and 4.0 before 4.0.1. UserAttributeSimilarityValidator incurred significant overhead in evaluating a submitted password that was artificially large in relation to the comparison values. In a situation where access to user registration was unrestricted, this provided a potential vector for a denial-of-service attack.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 2.2a1 to before 2.2.26 | 2.2.26 | Patch available | GHSA-53qw-q765-4fww |
| — | Django (PyPI) | 3.2a1 to before 3.2.11 | 3.2.11 | Patch available | GHSA-53qw-q765-4fww |
| — | Django (PyPI) | 4.0a1 to before 4.0.1 | 4.0.1 | Patch available | GHSA-53qw-q765-4fww |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 2.2a1 to before 2.2.26 Fixed in 2.2.26 Patch available GHSA-53qw-q765-4fww
- Django (PyPI) Vendor— Affected 3.2a1 to before 3.2.11 Fixed in 3.2.11 Patch available GHSA-53qw-q765-4fww
- Django (PyPI) Vendor— Affected 4.0a1 to before 4.0.1 Fixed in 4.0.1 Patch available GHSA-53qw-q765-4fww
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 2.2 to before 2.2.26; 3.2 to before 3.2.11; 4.0 to before 4.0.1 | Vulnerable | djangoproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 2.2 to before 2.2.26; 3.2 to before 3.2.11; 4.0 to before 4.0.1 Vulnerable ·djangoproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-53qw-q765-4fww Django (PyPI) Fixed in 2.2.26 Advisory →
- Fix · GHSA-53qw-q765-4fww Django (PyPI) Fixed in 3.2.11 Advisory →
- Fix · GHSA-53qw-q765-4fww Django (PyPI) Fixed in 4.0.1 Advisory →
Red Hat 1 advisory
- RHSA-2022:5498 Released 2022-07-05 · Red Hat rating ModerateSatellite 6.11 Release
- Red Hat Satellite 6.11 for RHEL 7 candlepin-4.1.13-1.el7sat, foreman-3.1.1.21-2.el7sat, libsolv-0.7.22-1.el7pc +4
- Red Hat Satellite 6.11 for RHEL 8 candlepin-4.1.13-1.el8sat, foreman-3.1.1.21-2.el8sat, libsolv-0.7.22-1.el8pc +8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 1.2 | Affected | No fix yet |
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet |
| Red Hat Ansible Tower 3 | Affected | No fix yet |
| Red Hat Ceph Storage 2 | Affected | No fix planned: Out of support scope |
| Red Hat Ceph Storage 3 | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 16.1 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 16.2 | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6 | Affected | No fix yet |
| Red Hat Update Infrastructure 3 for Cloud Providers | Affected | No fix planned: Will not fix |
| Red Hat Update Infrastructure 4 for Cloud Providers | Affected | No fix yet |
| Red Hat Satellite 6.11 for RHEL 8 | Fixed | RHSA-2022:5498 |
Not affected: 3 products
- Red Hat Satellite 6.11 for RHEL 7
- Red Hat Satellite 6.11 for RHEL 8
- Red Hat Storage 3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-45115
- 2026-10-03 Alias added: GHSA-53qw-q765-4fww
References
Patch 2
Advisory 4
Other 11
- https://groups.google.com/forum/#%21forum/django-announce
- https://github.com/django/django/commit/2135637fdd5ce994de110affef9e67dffdf77277
- https://github.com/django/django/commit/a8b32fe13bcaed1c0b772fdc53de84abc224fb20
- https://github.com/django/django/commit/df79ef03ac867c93caaa6be56bc69e66abfeef8f
- https://docs.djangoproject.com/en/4.0/releases/security
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2022-1.yaml
- https://groups.google.com/forum/#!forum/django-announce
- https://lists.fedoraproject.org/archives/list/[email protected]/message/B4SQG2EAF4WCI2SLRL6XRDJ3RPK3ZRDV
- https://security.netapp.com/advisory/ntap-20220121-0005
- https://www.djangoproject.com/weblog/2022/jan/04/security-releases
Sources
- CVE-2021-45115 · CVE Program
- CVE-2021-45115 · NVD
- FIRST EPSS
- GHSA-53qw-q765-4fww · GitHub Advisory Database · CC BY 4.0
- CVE-2021-45115 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences