In GenieACS 1.2.x before 1.2.8, the UI interface API is vulnerable to unauthenticated OS…
Priority MEDIUM 62CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
In GenieACS 1.2.x before 1.2.8, the UI interface API is vulnerable to unauthenticated OS command injection via the ping host argument (lib/ui/api.ts and lib/ping.ts). The vulnerability arises from insufficient input validation combined with a missing authorization check.
Why it matters now
EPSS 0.21901 97th percentileScored 2026-11-07
Fix Fixed genieacs (npm): 1.2.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | genieacs (npm) | before 1.2.8 | 1.2.8 | Patch available | GHSA-2877-693q-pj33 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- genieacs (npm) Vendor— Affected before 1.2.8 Fixed in 1.2.8 Patch available GHSA-2877-693q-pj33
Remediation
- Fix · GHSA-2877-693q-pj33 genieacs (npm) Fixed in 1.2.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-46704
- 2026-10-03 Alias added: GHSA-2877-693q-pj33
References
More Genieacs vulnerabilities
- TI-2025-35217 In GenieACS 1.2.13, an unauthenticated access vulnerability exists in the NBI API endpoint. CVSS 3.1HIGH 7.5
Sources
- CVE-2021-46704 · CVE Program
- CVE-2021-46704 · NVD
- FIRST EPSS
- GHSA-2877-693q-pj33 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences