grub2-once uses fixed file name in /var/tmp
Priority LOW 23CWE-377Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
A Insecure Temporary File vulnerability in grub-once of grub2 in SUSE Linux Enterprise Server 15 SP4, openSUSE Factory allows local attackers to truncate arbitrary files. This issue affects: SUSE Linux Enterprise Server 15 SP4 grub2 versions prior to 2.06-150400.7.1. SUSE openSUSE Factory grub2 versions prior to 2.06-18.1.
Why it matters now
EPSS 0.0024 15th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed SUSE Linux Enterprise Server 15 SP4 (SUSE): 2.06-150400.7.1openSUSE Factory (SUSE): 2.06-18.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE Linux Enterprise Server 15 SP4 | grub2 to before 2.06-150400.7.1 | 2.06-150400.7.1 | Patch available | CNA |
| SUSE | openSUSE Factory | grub2 to before 2.06-18.1 | 2.06-18.1 | Patch available | CNA |
- SUSE Linux Enterprise Server 15 SP4 VendorSUSE Affected grub2 to before 2.06-150400.7.1 Fixed in 2.06-150400.7.1 Patch available CNA
- openSUSE Factory VendorSUSE Affected grub2 to before 2.06-18.1 Fixed in 2.06-18.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gnu:grub2:*:*:*:*:*:*:*:* | before 2.06-150400.7.1 | Vulnerable | GNU |
| cpe:2.3:o:suse:linux_enterprise_server:15:sp4:*:*:*:*:*:* | 15 sp4 | Running on | SUSE |
| cpe:2.3:a:gnu:grub2:*:*:*:*:*:*:*:* | before 2.06-18.1 | Vulnerable | GNU |
| cpe:2.3:a:opensuse:factory:-:*:*:*:*:*:*:* | not specified by NVD | Running on | openSUSE |
- cpe:2.3:a:gnu:grub2:*:*:*:*:*:*:*:* Versions before 2.06-150400.7.1 Vulnerable ·GNU
- cpe:2.3:o:suse:linux_enterprise_server:15:sp4:*:*:*:*:*:* Versions 15 sp4 Running on ·SUSE
- cpe:2.3:a:gnu:grub2:*:*:*:*:*:*:*:* Versions before 2.06-18.1 Vulnerable ·GNU
- cpe:2.3:a:opensuse:factory:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·openSUSE
Remediation
- Fix · CNA SUSE Linux Enterprise Server 15 SP4 (SUSE) Fixed in 2.06-150400.7.1
- Fix · CNA openSUSE Factory (SUSE) Fixed in 2.06-18.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-46705
- 2026-10-03 Alias added: GHSA-p6fp-whjx-7g5m
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-46705 · CVE Program
- CVE-2021-46705 · NVD
- FIRST EPSS
- GHSA-p6fp-whjx-7g5m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences