The swagger-ui-dist package before 4.1.3 for Node.js could allow a remote attacker to…
Priority LOW 30CWE-1021Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-1021.
Summary
The swagger-ui-dist package before 4.1.3 for Node.js could allow a remote attacker to hijack the clicking action of the victim. By persuading a victim to visit a malicious Web site, a remote attacker could exploit this vulnerability to hijack the victim's click actions and possibly launch further attacks against the victim.
Why it matters now
EPSS 0.01488 74th percentileScored 2026-11-07
Fix Fixed swagger-ui-dist (npm): 4.1.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | swagger-ui-dist (npm) | before 4.1.3 | 4.1.3 | Patch available | GHSA-6c9x-mj3g-h47x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- swagger-ui-dist (npm) Vendor— Affected before 4.1.3 Fixed in 4.1.3 Patch available GHSA-6c9x-mj3g-h47x
Remediation
- Fix · GHSA-6c9x-mj3g-h47x swagger-ui-dist (npm) Fixed in 4.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-46708
- 2026-10-03 Alias added: GHSA-6c9x-mj3g-h47x
References
Sources
- CVE-2021-46708 · CVE Program
- CVE-2021-46708 · NVD
- FIRST EPSS
- GHSA-6c9x-mj3g-h47x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences