Read the docs
TI-2021-21463 Aliases CVE-2021-46743GHSA-8xf4-w7qw-pjjw

In Firebase PHP-JWT before 6.0.0, an algorithm-confusion issue (e.g., RS256 / HS256)…

Priority MEDIUM 41CWE-843Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution, Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-843, CWE-347 and the CVSS impact.

Summary

In Firebase PHP-JWT before 6.0.0, an algorithm-confusion issue (e.g., RS256 / HS256) exists via the kid (aka Key ID) header, when multiple types of keys are loaded in a key ring. This allows an attacker to forge tokens that validate under the incorrect key. NOTE: this provides a straightforward way to use the PHP-JWT library unsafely, but might not be considered a vulnerability in the library itself.

Why it matters now

EPSS 0.00916 60th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed firebase/php-jwt (Packagist): 6.0.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—firebase/php-jwt (Packagist)before 6.0.06.0.0Patch availableGHSA-8xf4-w7qw-pjjw
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • firebase/php-jwt (Packagist) Vendor— Affected before 6.0.0 Fixed in 6.0.0 Patch available GHSA-8xf4-w7qw-pjjw

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:google:firebase_php-jwt:*:*:*:*:*:*:*:*before 6.0.0VulnerableGoogle
  • cpe:2.3:a:google:firebase_php-jwt:*:*:*:*:*:*:*:* Versions before 6.0.0 Vulnerable ·Google

Remediation

  • Fix · GHSA-8xf4-w7qw-pjjw firebase/php-jwt (Packagist) Fixed in 6.0.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-46743
  2. 2026-10-03 Alias added: GHSA-8xf4-w7qw-pjjw

References

  • TI-2025-28840 php-jwt v6.11.0 was discovered to contain weak encryption. CVSS 3.1MEDIUM 6.5

Sources