python-ldap before 3.4.0 is vulnerable to a denial of service when ldap.schema is used…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 8 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-1333.
Summary
python-ldap before 3.4.0 is vulnerable to a denial of service when ldap.schema is used for untrusted schema definitions, because of a regular expression denial of service (ReDoS) flaw in the LDAP schema parser. By sending crafted regex input, a remote authenticated attacker could exploit this vulnerability to cause a denial of service condition.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | python-ldap (PyPI) | before 3.4.0 | 3.4.0 | Patch available | GHSA-qfr5-wjpw-q4c4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- python-ldap (PyPI) Vendor— Affected before 3.4.0 Fixed in 3.4.0 Patch available GHSA-qfr5-wjpw-q4c4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python-ldap:python-ldap:*:*:*:*:*:*:*:* | before 3.4.0 | Vulnerable | python-ldap |
- cpe:2.3:a:python-ldap:python-ldap:*:*:*:*:*:*:*:* Versions before 3.4.0 Vulnerable ·python-ldap
Remediation
- Fix · GHSA-qfr5-wjpw-q4c4 python-ldap (PyPI) Fixed in 3.4.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 1.2 | Affected | No fix planned: Will not fix |
| Red Hat Ansible Tower 3 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 9 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Out of support scope |
| Red Hat Quay 3 | Affected | No fix yet |
Not affected: 2 products
- Red Hat OpenStack Platform 16.1
- Red Hat OpenStack Platform 16.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-46823
- 2026-10-03 Alias added: GHSA-qfr5-wjpw-q4c4
References
More Python-ldap vulnerabilities
- TI-2025-38262 python-ldap Vulnerable to Improper Encoding or Escaping of Output and Improper Null Termination CVSS 4.0MEDIUM 5.5
- TI-2025-38261 python-ldap has sanitization bypass in ldap.filter.escape_filter_chars CVSS 4.0MEDIUM 5.5
Sources
- CVE-2021-46823 · CVE Program
- CVE-2021-46823 · NVD
- FIRST EPSS
- GHSA-qfr5-wjpw-q4c4 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-46823 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences