platform/x86: dell-smbios-wmi: Fix oops on rmmod dell_smbios
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 4 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: platform/x86: dell-smbios-wmi: Fix oops on rmmod dell_smbios init_dell_smbios_wmi() only registers the dell_smbios_wmi_driver on systems where the Dell WMI interface is supported. While exit_dell_smbios_wmi() unregisters it unconditionally, this leads to the following oops: [ 175.722921] ------------[ cut here ]------------ [ 175.722925] Unexpected driver unregister! [ 175.722939] WARNING: CPU: 1 PID: 3630 at drivers/base/driver.c:194 driver_unregister+0x38/0x40 ... [ 175.723089] Call Trace: [ 175.723094] cleanup_module+0x5/0xedd [dell_smbios] ... [ 175.723148] ---[ end trace 064c34e1ad49509d ]--- Make the unregister happen on the same condition the register happens to fix this.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.15 and later | 4.19.192, 5.4.122, 5.10.40, 5.12.7, 5.13 | Patch available | CNA |
- Linux VendorLinux Affected 4.15 and later Fixed in 4.19.192, 5.4.122, 5.10.40, 5.12.7, 5.13 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.15 to before 4.19.192; 4.20 to before 5.4.122; 5.5 to before 5.10.40; 5.11 to before 5.12.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.13:rc1:*:*:*:*:*:* | 5.13 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.13:rc2:*:*:*:*:*:* | 5.13 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.15 to before 4.19.192; 4.20 to before 5.4.122; 5.5 to before 5.10.40; 5.11 to before 5.12.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.13:rc1:*:*:*:*:*:* Versions 5.13 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.13:rc2:*:*:*:*:*:* Versions 5.13 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.192, 5.4.122, 5.10.40, 5.12.7, 5.13
Red Hat 2 advisories
- RHSA-2024:4352 Released 2024-07-08 · Red Hat rating Importantkernel-rt security and bug fix update
- Red Hat Enterprise Linux NFV (v. 8) kernel-rt-4.18.0-553.8.1.rt7.349.el8_10, kernel-rt-core-4.18.0-553.8.1.rt7.349.el8_10, kernel-rt-debug-4.18.0-553.8.1.rt7.349.el8_10 +9
- Red Hat Enterprise Linux RT (v. 8) kernel-rt-4.18.0-553.8.1.rt7.349.el8_10, kernel-rt-core-4.18.0-553.8.1.rt7.349.el8_10, kernel-rt-debug-4.18.0-553.8.1.rt7.349.el8_10 +7
- RHSA-2024:4211 Released 2024-07-02 · Red Hat rating Importantkernel security and bug fix update
- Red Hat Enterprise Linux BaseOS (v. 8) bpftool-4.18.0-553.8.1.el8_10, kernel-4.18.0-553.8.1.el8_10, kernel-abi-stablelists-4.18.0-553.8.1.el8_10 +19
- Red Hat Enterprise Linux CRB (v. 8) kernel-tools-libs-devel-4.18.0-553.8.1.el8_10
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2024:4211 |
| Red Hat Enterprise Linux CRB (v. 8) | Fixed | RHSA-2024:4211 |
| Red Hat Enterprise Linux NFV (v. 8) | Fixed | RHSA-2024:4352 |
| Red Hat Enterprise Linux RT (v. 8) | Fixed | RHSA-2024:4352 |
Not affected: 2 products
- Red Hat Enterprise Linux 9
- Red Hat Enterprise Linux BaseOS (v. 8)
Timeline
- 2026-10-02 Threatist record created from CVE-2021-47073
- 2026-10-03 Alias added: GHSA-ccpq-qrrm-9f6q
References
Patch 5
- https://git.kernel.org/stable/c/75cfc833da4a2111106d4c134e93e0c7f41e35e7
- https://git.kernel.org/stable/c/6fa78a6b9a3beb676a010dc489c1257f7e432525
- https://git.kernel.org/stable/c/0cf036a0d325200e6c27b90908e51195bbc557b1
- https://git.kernel.org/stable/c/8d746ea7c687bab060a2c05a35c449302406cd52
- https://git.kernel.org/stable/c/3a53587423d25c87af4b4126a806a0575104b45e
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2021-47073 · CVE Program
- CVE-2021-47073 · NVD
- FIRST EPSS
- GHSA-ccpq-qrrm-9f6q · GitHub Advisory Database · CC BY 4.0
- CVE-2021-47073 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences