iommu/vt-d: Fix sysfs leak in alloc_iommu()
Priority LOW 24CWE-401Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-401.
Summary
In the Linux kernel, the following vulnerability has been resolved: iommu/vt-d: Fix sysfs leak in alloc_iommu() iommu_device_sysfs_add() is called before, so is has to be cleaned on subsequent errors.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00238 14th percentileScored 2026-11-07
Fix Partial Linux (Linux): 4.14.235, 4.19.193, 5.4.124 +3Red Hat: 2 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.11 and later | 4.14.235, 4.19.193, 5.4.124, 5.10.42, 5.12.9, 5.13 | Patch available | CNA |
- Linux VendorLinux Affected 4.11 and later Fixed in 4.14.235, 4.19.193, 5.4.124, 5.10.42, 5.12.9, 5.13 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.11 to before 4.14.235; 4.15 to before 4.19.193; 4.20 to before 5.4.124; 5.5 to before 5.10.42; 5.11 to before 5.12.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.13:rc1:*:*:*:*:*:* | 5.13 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.13:rc2:*:*:*:*:*:* | 5.13 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.13:rc3:*:*:*:*:*:* | 5.13 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.11 to before 4.14.235; 4.15 to before 4.19.193; 4.20 to before 5.4.124; 5.5 to before 5.10.42; 5.11 to before 5.12.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.13:rc1:*:*:*:*:*:* Versions 5.13 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.13:rc2:*:*:*:*:*:* Versions 5.13 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.13:rc3:*:*:*:*:*:* Versions 5.13 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.14.235, 4.19.193, 5.4.124, 5.10.42, 5.12.9, 5.13
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix yet |
Not affected: 2 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-47177
- 2026-10-03 Alias added: GHSA-3q2v-922f-6rc3
References
Patch 6
- https://git.kernel.org/stable/c/22da9f4978381a99f1abaeaf6c9b83be6ab5ddd8
- https://git.kernel.org/stable/c/2ec5e9bb6b0560c90d315559c28a99723c80b996
- https://git.kernel.org/stable/c/044bbe8b92ab4e542de7f6c93c88ea65cccd8e29
- https://git.kernel.org/stable/c/f01134321d04f47c718bb41b799bcdeda27873d2
- https://git.kernel.org/stable/c/ca466561eef36d1ec657673e3944eb6340bddb5b
- https://git.kernel.org/stable/c/0ee74d5a48635c848c20f152d0d488bf84641304
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2021-47177 · CVE Program
- CVE-2021-47177 · NVD
- FIRST EPSS
- GHSA-3q2v-922f-6rc3 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-47177 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences