scsi: advansys: Fix kernel pointer leak
Priority LOW 24Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: scsi: advansys: Fix kernel pointer leak Pointers should be printed with %p or %px rather than cast to 'unsigned long' and printed with %lx. Change %lx to %p to print the hashed pointer.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00226 13th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 4.4.293, 4.9.291, 4.14.256 +5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.10 and later | 4.4.293, 4.9.291, 4.14.256, 4.19.218, 5.4.162, 5.10.82, 5.15.5, 5.16 | Patch available | CNA |
- Linux VendorLinux Affected 3.10 and later Fixed in 4.4.293, 4.9.291, 4.14.256, 4.19.218, 5.4.162, 5.10.82, 5.15.5, 5.16 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 4.4.293; 4.5 to before 4.9.291; 4.10 to before 4.14.256; 4.15 to before 4.19.218; 4.20 to before 5.4.162; 5.5 to before 5.10.82; 5.11 to before 5.15.5 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 4.4.293; 4.5 to before 4.9.291; 4.10 to before 4.14.256; 4.15 to before 4.19.218; 4.20 to before 5.4.162; 5.5 to before 5.10.82; 5.11 to before 5.15.5 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.4.293, 4.9.291, 4.14.256, 4.19.218, 5.4.162, 5.10.82, 5.15.5, 5.16
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-47216
- 2026-10-03 Alias added: GHSA-7vqx-fpjm-pj2j
References
Patch 8
- https://git.kernel.org/stable/c/06d7d12efb5c62db9dea15141ae2b322c2719515
- https://git.kernel.org/stable/c/ad19f7046c24f95c674fbea21870479b2b9f5bab
- https://git.kernel.org/stable/c/5612287991debe310c914600599bd59511ababfb
- https://git.kernel.org/stable/c/f5a0ba4a9b5e70e7b2f767636d26523f9d1ac59d
- https://git.kernel.org/stable/c/cc248790bfdcf879e3094fa248c85bf92cdf9dae
- https://git.kernel.org/stable/c/055eced3edf5b675d12189081303f6285ef26511
- https://git.kernel.org/stable/c/27490ae6a85a70242d80615ca74d0362a820d6a7
- https://git.kernel.org/stable/c/d4996c6eac4c81b8872043e9391563f67f13e406
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2021-47216 · CVE Program
- CVE-2021-47216 · NVD
- FIRST EPSS
- GHSA-7vqx-fpjm-pj2j · GitHub Advisory Database · CC BY 4.0
- CVE-2021-47216 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences