KVM: PPC: Fix kvm_arch_vcpu_ioctl vcpu_load leak
Priority LOW 34CWE-401Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-401.
Summary
In the Linux kernel, the following vulnerability has been resolved: KVM: PPC: Fix kvm_arch_vcpu_ioctl vcpu_load leak vcpu_put is not called if the user copy fails. This can result in preempt notifier corruption and crashes, among other issues.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00236 14th percentileScored 2026-11-07
Fix Partial Linux (Linux): 4.19.199, 5.4.136, 5.10.54 +2Red Hat: 1 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.18 and later | 4.19.199, 5.4.136, 5.10.54, 5.13.6, 5.14 | Patch available | CNA |
- Linux VendorLinux Affected 4.18 and later Fixed in 4.19.199, 5.4.136, 5.10.54, 5.13.6, 5.14 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.18 to before 4.19.199; 4.20 to before 5.4.136; 5.5 to before 5.10.54; 5.11 to before 5.13.6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.14:rc1:*:*:*:*:*:* | 5.14 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.14:rc2:*:*:*:*:*:* | 5.14 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.18 to before 4.19.199; 4.20 to before 5.4.136; 5.5 to before 5.10.54; 5.11 to before 5.13.6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.14:rc1:*:*:*:*:*:* Versions 5.14 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.14:rc2:*:*:*:*:*:* Versions 5.14 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.199, 5.4.136, 5.10.54, 5.13.6, 5.14
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
Not affected: 3 products
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-47296
- 2026-10-03 Alias added: GHSA-28c9-mq9x-7pcr
References
Patch 5
- https://git.kernel.org/stable/c/9bafc34dc4ad0cef18727c557f21ed3c3304df50
- https://git.kernel.org/stable/c/f38527f1890543cdfca8dfd06f75f9887cce6151
- https://git.kernel.org/stable/c/e14ef1095387f764d95614d3ec9e4d07c82a3533
- https://git.kernel.org/stable/c/a4a488915feaad38345cc01b80d52e8200ff5209
- https://git.kernel.org/stable/c/bc4188a2f56e821ea057aca6bf444e138d06c252
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2021-47296 · CVE Program
- CVE-2021-47296 · NVD
- FIRST EPSS
- GHSA-28c9-mq9x-7pcr · GitHub Advisory Database · CC BY 4.0
- CVE-2021-47296 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences