irqchip/gic-v3-its: Fix potential VPE leak on error
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-193 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: irqchip/gic-v3-its: Fix potential VPE leak on error In its_vpe_irq_domain_alloc, when its_vpe_init() returns an error, there is an off-by-one in the number of VPEs to be freed. Fix it by simply passing the number of VPEs allocated, which is the index of the loop iterating over the VPEs. [maz: fixed commit message]
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.14 and later | 4.14.249, 4.19.209, 5.4.150, 5.10.70, 5.14.9, 5.15 | Patch available | CNA |
- Linux VendorLinux Affected 4.14 and later Fixed in 4.14.249, 4.19.209, 5.4.150, 5.10.70, 5.14.9, 5.15 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.14 to before 4.14.249; 4.15 to before 4.19.209; 4.20 to before 5.4.150; 5.5 to before 5.10.70; 5.11 to before 5.14.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.15:rc1:*:*:*:*:*:* | 5.15 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.15:rc2:*:*:*:*:*:* | 5.15 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.14 to before 4.14.249; 4.15 to before 4.19.209; 4.20 to before 5.4.150; 5.5 to before 5.10.70; 5.11 to before 5.14.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.15:rc1:*:*:*:*:*:* Versions 5.15 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.15:rc2:*:*:*:*:*:* Versions 5.15 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.14.249, 4.19.209, 5.4.150, 5.10.70, 5.14.9, 5.15
Red Hat 3 advisories
- RHSA-2024:5101 Released 2024-08-08 · Red Hat rating Importantkernel security update
- Red Hat Enterprise Linux BaseOS (v. 8) bpftool-4.18.0-553.16.1.el8_10, kernel-4.18.0-553.16.1.el8_10, kernel-abi-stablelists-4.18.0-553.16.1.el8_10 +19
- Red Hat Enterprise Linux CRB (v. 8) kernel-tools-libs-devel-4.18.0-553.16.1.el8_10
- RHSA-2024:5102 Released 2024-08-08 · Red Hat rating Importantkernel-rt security update
- Red Hat Enterprise Linux NFV (v. 8) kernel-rt-4.18.0-553.16.1.rt7.357.el8_10, kernel-rt-core-4.18.0-553.16.1.rt7.357.el8_10, kernel-rt-debug-4.18.0-553.16.1.rt7.357.el8_10 +9
- Red Hat Enterprise Linux RT (v. 8) kernel-rt-4.18.0-553.16.1.rt7.357.el8_10, kernel-rt-core-4.18.0-553.16.1.rt7.357.el8_10, kernel-rt-debug-4.18.0-553.16.1.rt7.357.el8_10 +7
- RHSA-2022:8267 Released 2022-11-15 · Red Hat rating Moderatekernel security, bug fix, and enhancement update
- Red Hat CodeReady Linux Builder (v. 9) kernel-tools-libs-devel-5.14.0-162.6.1.el9_1
- Red Hat Enterprise Linux AppStream (v. 9) kernel-debug-devel-5.14.0-162.6.1.el9_1, kernel-debug-devel-matched-5.14.0-162.6.1.el9_1, kernel-devel-5.14.0-162.6.1.el9_1 +5
- Red Hat Enterprise Linux BaseOS (v. 9) bpftool-5.14.0-162.6.1.el9_1, kernel-5.14.0-162.6.1.el9_1, kernel-abi-stablelists-5.14.0-162.6.1.el9_1 +14
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2022:8267 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2022:8267 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2024:5101 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2022:8267 |
| Red Hat Enterprise Linux CRB (v. 8) | Fixed | RHSA-2024:5101 |
| Red Hat Enterprise Linux NFV (v. 8) | Fixed | RHSA-2024:5102 |
| Red Hat Enterprise Linux RT (v. 8) | Fixed | RHSA-2024:5102 |
Not affected: 2 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2021-47373
- 2026-10-03 Alias added: GHSA-m9r6-94f7-4j6m
- 2026-10-29 Affected versions changed · Red Hat
References
Patch 6
- https://git.kernel.org/stable/c/7d39992d45acd6f2d6b2f62389c55b61fb3d486b
- https://git.kernel.org/stable/c/5701e8bff314c155e7afdc467b1e0389d86853d0
- https://git.kernel.org/stable/c/42d3711c23781045e7a5cd28536c774b9a66d20b
- https://git.kernel.org/stable/c/568662e37f927e3dc3e475f3ff7cf4ab7719c5e7
- https://git.kernel.org/stable/c/e0c1c2e5da19685a20557a50f10c6aa4fa26aa84
- https://git.kernel.org/stable/c/280bef512933b2dda01d681d8cbe499b98fc5bdd
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2021-47373 · CVE Program
- CVE-2021-47373 · NVD
- FIRST EPSS
- GHSA-m9r6-94f7-4j6m · GitHub Advisory Database · CC BY 4.0
- CVE-2021-47373 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences