ipack: ipoctal: fix module reference leak
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-200.
Summary
In the Linux kernel, the following vulnerability has been resolved: ipack: ipoctal: fix module reference leak A reference to the carrier module was taken on every open but was only released once when the final reference to the tty struct was dropped. Fix this by taking the module reference and initialising the tty driver data when installing the tty.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.18 and later | 4.4.286, 4.9.285, 4.14.249, 4.19.209, 5.4.151, 5.10.71, 5.14.10, 5.15 | Patch available | CNA |
- Linux VendorLinux Affected 3.18 and later Fixed in 4.4.286, 4.9.285, 4.14.249, 4.19.209, 5.4.151, 5.10.71, 5.14.10, 5.15 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 3.18 to before 4.4.286; 4.5 to before 4.9.285; 4.10 to before 4.14.249; 4.15 to before 4.19.209; 4.20 to before 5.4.151; 5.5 to before 5.10.71; 5.11 to before 5.14.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.15:rc1:*:*:*:*:*:* | 5.15 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.15:rc2:*:*:*:*:*:* | 5.15 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.15:rc3:*:*:*:*:*:* | 5.15 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 3.18 to before 4.4.286; 4.5 to before 4.9.285; 4.10 to before 4.14.249; 4.15 to before 4.19.209; 4.20 to before 5.4.151; 5.5 to before 5.10.71; 5.11 to before 5.14.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.15:rc1:*:*:*:*:*:* Versions 5.15 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.15:rc2:*:*:*:*:*:* Versions 5.15 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.15:rc3:*:*:*:*:*:* Versions 5.15 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.4.286, 4.9.285, 4.14.249, 4.19.209, 5.4.151, 5.10.71, 5.14.10, 5.15
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-47403
- 2026-10-03 Alias added: GHSA-jmm7-6r74-7f4p
References
Patch 8
- https://git.kernel.org/stable/c/31398849b84ebae0d43a1cf379cb9895597f221a
- https://git.kernel.org/stable/c/c0adb5a947dec6cff7050ec56d78ecd3916f9ce6
- https://git.kernel.org/stable/c/dde4c1429b97383689f755ce92b4ed1e84a9c92b
- https://git.kernel.org/stable/c/9c5b77a7ffc983b2429ce158b50497c5d3c86a69
- https://git.kernel.org/stable/c/3253c87e1e5bc0107aab773af2f135ebccf38666
- https://git.kernel.org/stable/c/7cea848678470daadbfdaa6a112b823c290f900c
- https://git.kernel.org/stable/c/811178f296b16af30264def74c8d2179a72d5562
- https://git.kernel.org/stable/c/bb8a4fcb2136508224c596a7e665bdba1d7c3c27
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2021-47403 · CVE Program
- CVE-2021-47403 · NVD
- FIRST EPSS
- GHSA-jmm7-6r74-7f4p · GitHub Advisory Database · CC BY 4.0
- CVE-2021-47403 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences