Grocery crud 1.6.4 - 'order_by' SQL Injection
Priority HIGH 77CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
Grocery Crud 1.6.4 contains a SQL injection vulnerability in the order_by parameter that allows remote attackers to manipulate database queries. Attackers can inject malicious SQL code through the order_by[] parameter in POST requests to the ajax_list endpoint to potentially extract or modify database information.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00577 47th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Grocery crud (Grocerycrud): v2.0.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Grocerycrud | Grocery crud | before v2.0.1 | v2.0.1 | Patch available | CNA |
- Grocery crud VendorGrocerycrud Affected before v2.0.1 Fixed in v2.0.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:grocerycrud:grocery_crud:*:*:*:*:*:*:*:* | before 2.0.1 | Vulnerable | Grocerycrud |
- cpe:2.3:a:grocerycrud:grocery_crud:*:*:*:*:*:*:*:* Versions before 2.0.1 Vulnerable ·Grocerycrud
Remediation
- Fix · CNA Grocery crud (Grocerycrud) Fixed in v2.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-47811
- 2026-10-03 Alias added: GHSA-93r3-3845-hqh2
- 2026-11-07 Affected versions changed · CNA
References
Exploit 1
Sources
- CVE-2021-47811 · CVE Program
- CVE-2021-47811 · NVD
- FIRST EPSS
- GHSA-93r3-3845-hqh2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences