Read the docs
TI-2021-22548 Aliases CVE-2021-47935GHSA-444r-2whx-3685

Sentry 8.2.0 Remote Code Execution via Pickle Deserialization

Priority HIGH 73CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Sentry 8.2.0 contains a remote code execution vulnerability that allows authenticated superusers to execute arbitrary commands by injecting malicious pickle-serialized objects through the audit log entry data parameter. Attackers can submit crafted POST requests to the admin audit log endpoint with base64-encoded compressed pickle payloads in the data field to achieve code execution with application privileges.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00927 60th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed sentry (PyPI): 8.1.4, 8.2.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
SentrySentry8.2.0—No fix listedCNA
—sentry (PyPI)before 8.1.48.1.4Patch availableGHSA-444r-2whx-3685
—sentry (PyPI)8.2.0 to before 8.2.28.2.2Patch availableGHSA-444r-2whx-3685
  • Sentry VendorSentry Affected 8.2.0 Fixed in — No fix listed CNA
  • sentry (PyPI) Vendor— Affected before 8.1.4 Fixed in 8.1.4 Patch available GHSA-444r-2whx-3685
  • sentry (PyPI) Vendor— Affected 8.2.0 to before 8.2.2 Fixed in 8.2.2 Patch available GHSA-444r-2whx-3685

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sentry:sentry:8.2.0:*:*:*:*:*:*:*8.2.0VulnerableSentry
  • cpe:2.3:a:sentry:sentry:8.2.0:*:*:*:*:*:*:* Versions 8.2.0 Vulnerable ·Sentry

Remediation

  • Fix · GHSA-444r-2whx-3685 sentry (PyPI) Fixed in 8.1.4 Advisory →
  • Fix · GHSA-444r-2whx-3685 sentry (PyPI) Fixed in 8.2.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-47935
  2. 2026-10-03 Alias added: GHSA-444r-2whx-3685

References

  • TI-2026-21018 Sentry allows unauthorized access to event data across organizational boundaries CVSS 4.0MEDIUM 5.7
  • TI-2026-30656 Sentry: Improper authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.8
  • TI-2026-21634 Sentry: Improper Authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.1
  • TI-2026-37904 Sentry: Inefficient Regular Expression Complexity in sentry CVSS 3.1HIGH 7.5
  • TI-2023-20488 Sentry vulnerable to privilege escalation via ApiTokensEndpoint CVSS 3.1HIGH 8.1
  • TI-2023-18620 Sentry vulnerable to improper authorization on debug and artifact file downloads CVSS 3.1HIGH 7.7
See all 15 →

Sources