Read the docs
TI-2021-22604 Aliases GHSA-h96f-fc7c-9r55

Regex denial of service vulnerability in codesample plugin

Priority LOW 38CWE-400Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Denial of service
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-400.

Summary

### Impact A regex denial of service (ReDoS) vulnerability was discovered in a dependency of the `codesample` plugin. The vulnerability allowed poorly formed ruby code samples to lock up the browser while performing syntax highlighting. This impacts users of the `codesample` plugin using TinyMCE 5.5.1 or lower. ### Patches This vulnerability has been patched in TinyMCE 5.6.0 by upgrading to a version of the dependency without the vulnerability. ### Workarounds To work around this vulnerability, either: - Upgrade to TinyMCE 5.6.0 or higher - Disable the `codesample` plugin - Disable ruby code samples using the [codesample_languages](https://www.tiny.cloud/docs/plugins/opensource/codesample/#exampleusingcodesample_languages) setting - Override the PrismJS syntax highlighter to version 1.21.0 or higher using the [codesample_global_prismjs](https://www.tiny.cloud/docs/plugins/opensource/codesample/#codesample_global_prismjs) setting ### Acknowledgements Tiny Technologies would like to thank Erik Krogh Kristensen at GitHub for discovering this vulnerability. ### References https://www.tiny.cloud/docs/release-notes/release-notes56/#securityfixes ### For more information If you have any questions or comments about this advisory: * Open an issue in the [TinyMCE repo](http://github.com/tinymce/tinymce/issues) * Email us at [[email protected]](mailto:[email protected])

Why it matters now

Fix Fixed tinymce (npm): 5.6.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—tinymce (npm)before 5.6.05.6.0Patch availableGHSA-h96f-fc7c-9r55
  • tinymce (npm) Vendor— Affected before 5.6.0 Fixed in 5.6.0 Patch available GHSA-h96f-fc7c-9r55

Remediation

  • Fix · GHSA-h96f-fc7c-9r55 tinymce (npm) Fixed in 5.6.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-h96f-fc7c-9r55

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences