Read the docs
TI-2021-22616 Aliases GHSA-cqff-fx2x-p86v

botframework-connector vulnerable to Improper Authentication

Priority LOW 38CWE-287Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-287.

Summary

### Impact A maliciously crafted claim may be incorrectly authenticated by the bot. Impacts bots that are not configured to be used as a Skill. This vulnerability requires an attacker to have internal knowledge of the bot. ### Patches The problem has been patched in all affected versions. Please see the list of patched versions for the most appropiate one for your individual case. ### Workarounds Users who do not wish or are not able to upgrade can add an authentication configuration containing ClaimsValidator, which throws an exception if Claims are Skill Claims. For detailed instructions, see the link in the References section. ### For more information If you have any questions or comments about this advisory: * Open an issue in [Microsoft Bot Builder SDK](https://github.com/microsoft/botframework-sdk) * Email us at [[email protected]](mailto:[email protected])

Why it matters now

Fix Fixed botframework-connector (PyPI): 4.7.2, 4.8.1, 4.9.3 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—botframework-connector (PyPI)4.7.0 to before 4.7.24.7.2Patch availableGHSA-cqff-fx2x-p86v
—botframework-connector (PyPI)4.8.0 to before 4.8.14.8.1Patch availableGHSA-cqff-fx2x-p86v
—botframework-connector (PyPI)4.9.0 to before 4.9.34.9.3Patch availableGHSA-cqff-fx2x-p86v
—botframework-connector (PyPI)4.10.0 to before 4.10.14.10.1Patch availableGHSA-cqff-fx2x-p86v
  • botframework-connector (PyPI) Vendor— Affected 4.7.0 to before 4.7.2 Fixed in 4.7.2 Patch available GHSA-cqff-fx2x-p86v
  • botframework-connector (PyPI) Vendor— Affected 4.8.0 to before 4.8.1 Fixed in 4.8.1 Patch available GHSA-cqff-fx2x-p86v
  • botframework-connector (PyPI) Vendor— Affected 4.9.0 to before 4.9.3 Fixed in 4.9.3 Patch available GHSA-cqff-fx2x-p86v
  • botframework-connector (PyPI) Vendor— Affected 4.10.0 to before 4.10.1 Fixed in 4.10.1 Patch available GHSA-cqff-fx2x-p86v

Remediation

  • Fix · GHSA-cqff-fx2x-p86v botframework-connector (PyPI) Fixed in 4.7.2 Advisory →
  • Fix · GHSA-cqff-fx2x-p86v botframework-connector (PyPI) Fixed in 4.8.1 Advisory →
  • Fix · GHSA-cqff-fx2x-p86v botframework-connector (PyPI) Fixed in 4.9.3 Advisory →
  • Fix · GHSA-cqff-fx2x-p86v botframework-connector (PyPI) Fixed in 4.10.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-cqff-fx2x-p86v

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences