Read the docs
TI-2021-22620 Aliases GHSA-hfwx-c7q6-g54c

Vulnerability allowing for reading internal HTTP resources

Priority LOW 38CWE-552Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Information disclosure
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-552.

Summary

### Impact The vulnerability allows for reading and outputting files served by other services on the internal network in which the export server is hosted. If the export server is exposed to the internet, this potentially allows a malicious user to gain read access to internal web-resources. The impact is limited to internal services that serve content via. HTTP(S), and requires the attacker to know internal hostnames/IP addresses. The previous versions have been marked as deprecated on NPM. ### Patches Version 2.1.0 released alongside this security advisory addresses the issue. **Please note that this release is not backwards compatible out of the box. See the [changelog](https://github.com/highcharts/node-export-server/blob/master/CHANGELOG.md) for details.** Additionally, it's also recommended to upgrade to the latest version of Highcharts to get the added input sanitation implemented in version 9.0 and later. ### Workarounds There are no known workarounds to the issue - an upgrade to version 2.1.0 is required. ### For more information If you have any questions or comments about this advisory: * Open an issue in [the export server issue tracker](https://github.com/highcharts/node-export-server/issues) * Email us at [[email protected]](mailto:[email protected])

Why it matters now

Fix Fixed highcharts-export-server (npm): 2.1.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—highcharts-export-server (npm)before 2.1.02.1.0Patch availableGHSA-hfwx-c7q6-g54c
  • highcharts-export-server (npm) Vendor— Affected before 2.1.0 Fixed in 2.1.0 Patch available GHSA-hfwx-c7q6-g54c

Remediation

  • Fix · GHSA-hfwx-c7q6-g54c highcharts-export-server (npm) Fixed in 2.1.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-hfwx-c7q6-g54c

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences