Read the docs
TI-2021-22621 Aliases GHSA-pjj4-jjgc-h3r8

Authenticated remote code execution using plugin manager without ACL permissions.

Priority LOW 38CWE-74Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact Authenticated remote code execution using plugin manager without ACL permissions. ### Patches We recommend to update to the current version 6.3.5.2. You can get the update to 6.3.5.2 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 ### Workarounds For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659 ### For more information https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-03-2021

Why it matters now

Fix Fixed shopware/platform (Packagist): 6.3.5.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—shopware/platform (Packagist)before 6.3.5.26.3.5.2Patch availableGHSA-pjj4-jjgc-h3r8
  • shopware/platform (Packagist) Vendor— Affected before 6.3.5.2 Fixed in 6.3.5.2 Patch available GHSA-pjj4-jjgc-h3r8

Remediation

  • Fix · GHSA-pjj4-jjgc-h3r8 shopware/platform (Packagist) Fixed in 6.3.5.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-pjj4-jjgc-h3r8

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences