Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19
Priority LOW 38CWE-402Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
Vulnerability in OSGi integration in `com.vaadin:flow-server` versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request. - https://vaadin.com/security/cve-2021-31407
Why it matters now
Fix Fixed com.vaadin:vaadin-bom (Maven): 14.4.10, 19.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | com.vaadin:vaadin-bom (Maven) | 12.0.0 to before 14.4.10 | 14.4.10 | Patch available | GHSA-j9wr-49vq-rm5g |
| — | com.vaadin:vaadin-bom (Maven) | 19.0.0 to before 19.0.1 | 19.0.1 | Patch available | GHSA-j9wr-49vq-rm5g |
- com.vaadin:vaadin-bom (Maven) Vendor— Affected 12.0.0 to before 14.4.10 Fixed in 14.4.10 Patch available GHSA-j9wr-49vq-rm5g
- com.vaadin:vaadin-bom (Maven) Vendor— Affected 19.0.0 to before 19.0.1 Fixed in 19.0.1 Patch available GHSA-j9wr-49vq-rm5g
Remediation
- Fix · GHSA-j9wr-49vq-rm5g com.vaadin:vaadin-bom (Maven) Fixed in 14.4.10 Advisory →
- Fix · GHSA-j9wr-49vq-rm5g com.vaadin:vaadin-bom (Maven) Fixed in 19.0.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-j9wr-49vq-rm5g
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences