Read the docs
TI-2021-22641 Aliases GHSA-4mg9-vhxq-vm7j

SQL Server LIMIT / OFFSET SQL Injection in laravel/framework and illuminate/database

Priority LOW 38CWE-89Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
SQL injection
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-89.

Summary

### Impact Those using SQL Server with Laravel and allowing user input to be passed directly to the `limit` and `offset` functions are vulnerable to SQL injection. Other database drivers such as MySQL and Postgres are not affected by this vulnerability. ### Patches This problem has been patched on Laravel versions 6.20.26, 7.30.5, and 8.40.0. ### Workarounds You may workaround this vulnerability by ensuring that only integers are passed to the `limit` and `offset` functions, as well as the `skip` and `take` functions.

Why it matters now

Fix Fixed laravel/framework (Packagist): 8.40.0, 6.20.26illuminate/database (Packagist): 8.40.0, 6.20.26

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—laravel/framework (Packagist)8.0.0 to before 8.40.08.40.0Patch availableGHSA-4mg9-vhxq-vm7j
—laravel/framework (Packagist)before 6.20.266.20.26Patch availableGHSA-4mg9-vhxq-vm7j
—illuminate/database (Packagist)8.0.0 to before 8.40.08.40.0Patch availableGHSA-4mg9-vhxq-vm7j
—illuminate/database (Packagist)before 6.20.266.20.26Patch availableGHSA-4mg9-vhxq-vm7j
  • laravel/framework (Packagist) Vendor— Affected 8.0.0 to before 8.40.0 Fixed in 8.40.0 Patch available GHSA-4mg9-vhxq-vm7j
  • laravel/framework (Packagist) Vendor— Affected before 6.20.26 Fixed in 6.20.26 Patch available GHSA-4mg9-vhxq-vm7j
  • illuminate/database (Packagist) Vendor— Affected 8.0.0 to before 8.40.0 Fixed in 8.40.0 Patch available GHSA-4mg9-vhxq-vm7j
  • illuminate/database (Packagist) Vendor— Affected before 6.20.26 Fixed in 6.20.26 Patch available GHSA-4mg9-vhxq-vm7j

Remediation

  • Fix · GHSA-4mg9-vhxq-vm7j laravel/framework (Packagist) Fixed in 8.40.0 Advisory →
  • Fix · GHSA-4mg9-vhxq-vm7j laravel/framework (Packagist) Fixed in 6.20.26 Advisory →
  • Fix · GHSA-4mg9-vhxq-vm7j illuminate/database (Packagist) Fixed in 8.40.0 Advisory →
  • Fix · GHSA-4mg9-vhxq-vm7j illuminate/database (Packagist) Fixed in 6.20.26 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-4mg9-vhxq-vm7j

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences