Unauthorized access through URL manipulation
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-552.
Summary
### Impact The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. ### Patches The vulnerability has been patched in version 1.2.65 of the `master` branch, version 1.1.113 of the 1.1.x series, and version 1.0.12 of the `stable` branch. The Docker image on docker.io has been patched. ### Workarounds If upgrading is not possible, manually apply the changes of https://github.com/jhpyle/docassemble/commit/e3dbf6ce054b3c0310996f0657289f5eed0a73fe and restart the server (e.g., by pressing Save on the Configuration screen). ### Credit The vulnerability was discovered by Jim Platania of Seiso LLC (@jimmio). ### For more information If you have any questions or comments about this advisory: * Open an issue in [docassemble](https://github.com/jhpyle/docassemble/issues) * Join the [Slack channel](https://join.slack.com/t/docassemble/shared_invite/zt-ohrn8y9z-_Fb3RAl~JPBU6Km7odBPfQ) * Email us at [[email protected]](mailto:[email protected])
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | docassemble (PyPI) | before 1.2.65 | 1.2.65 | Patch available | GHSA-qrmm-w4v4-q7f8 |
- docassemble (PyPI) Vendor— Affected before 1.2.65 Fixed in 1.2.65 Patch available GHSA-qrmm-w4v4-q7f8
Remediation
- Fix · GHSA-qrmm-w4v4-q7f8 docassemble (PyPI) Fixed in 1.2.65 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-qrmm-w4v4-q7f8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences