Incorrect handling of credential expiry by /nats-io/nats-server
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-284.
Summary
(This advisory is canonically https://advisories.nats.io/CVE/CVE-2020-26892.txt ) ## Problem Description NATS nats-server through 2020-10-07 has Incorrect Access Control because of how expired credentials are handled. The NATS accounts system has expiration timestamps on credentials; the <https://github.com/nats-io/jwt> library had an API which encouraged misuse and an `IsRevoked()` method which misused its own API. A new `IsClaimRevoked()` method has correct handling and the nats-server has been updated to use this. The old `IsRevoked()` method now always returns true and other client code will have to be updated to avoid calling it. The CVE identifier should cover any application using the old JWT API, where the nats-server is one of those applications. ## Affected versions #### JWT library * all versions prior to 1.1.0 * fixed after nats-io/jwt PR 103 landed (2020-10-06) #### NATS Server * Version 2 prior to 2.1.9 + 2.0.0 through and including 2.1.8 are vulnerable. * fixed with nats-io/nats-server PRs 1632, 1635, 1645 ## Impact Time-based credential expiry did not work. ## Workaround Have credentials which only expire after fixes can be deployed. ## Solution Upgrade the JWT dependency in any application using it. Upgrade the NATS server if using NATS Accounts.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | github.com/nats-io/nats-server/v2 (Go) | before 2.1.9 | 2.1.9 | Patch available | GHSA-2c64-vj8g-vwrq |
- github.com/nats-io/nats-server/v2 (Go) Vendor— Affected before 2.1.9 Fixed in 2.1.9 Patch available GHSA-2c64-vj8g-vwrq
Remediation
- Fix · GHSA-2c64-vj8g-vwrq github.com/nats-io/nats-server/v2 (Go) Fixed in 2.1.9 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-2c64-vj8g-vwrq
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences