Read the docs
TI-2021-22668 Aliases GHSA-5vm8-hhgr-jcjp

Cross-site scripting vulnerability in TinyMCE

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

### Impact A cross-site scripting (XSS) vulnerability was discovered in the URL sanitization logic of the core parser for `form` elements. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor using the clipboard or APIs, and then submitting the form. However, as TinyMCE does not allow forms to be submitted while editing, the vulnerability could only be triggered when the content was previewed or rendered outside of the editor. This impacts all users who are using TinyMCE 5.7.0 or lower. ### Patches This vulnerability has been patched in TinyMCE 5.7.1 by improved URL sanitization logic. ### Workarounds To work around this vulnerability, either: - Upgrade to TinyMCE 5.7.1 or higher - Manually sanitize `form` URL attributes using a [TinyMCE node filter](https://www.tiny.cloud/docs/api/tinymce.html/tinymce.html.domparser/#addnodefilter). - Disable `form` elements in your content using the [invalid_elements](https://www.tiny.cloud/docs/configure/content-filtering/#invalid_elements) setting. #### Example: Sanitizing using a node filter ```js editor.parser.addNodeFilter('form', function(nodes) { nodes.forEach(function(node) { if (node.attributes) { node.attributes.forEach(function(attr) { var name = attr.name; var value = attr.value; // Sanitize the attribute value here or remove it entirely var sanitizedValue = ...; node.attr(name, santizedValue); }); } }); }); ``` #### Example: Using invalid_elements ```js invalid_elements: 'form' ``` ### Acknowledgements Tiny Technologies would like to thank Mikhail Khramenkov at Solar Security Research Team for discovering this vulnerability. ### References https://www.tiny.cloud/docs/release-notes/release-notes571/#securityfixes ### For more information If you have any questions or comments about this advisory: * Open an issue in the [TinyMCE repo](https://github.com/tinymce/tinymce/issues) * Email us at [[email protected]](mailto:[email protected])

Why it matters now

Fix Fixed tinymce (npm): 5.7.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—tinymce (npm)before 5.7.15.7.1Patch availableGHSA-5vm8-hhgr-jcjp
  • tinymce (npm) Vendor— Affected before 5.7.1 Fixed in 5.7.1 Patch available GHSA-5vm8-hhgr-jcjp

Remediation

  • Fix · GHSA-5vm8-hhgr-jcjp tinymce (npm) Fixed in 5.7.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-5vm8-hhgr-jcjp

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences