Incorrect version tags linked to external repository
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-494.
Summary
### Impact A security incident caused a number of incorrect version tags to be pushed to the Parse Server repository. These version tags linked to a personal fork of a contributor who had write access to the repository. The code to which these tags linked has not been reviewed or approved by Parse Platform. Even though no releases were published with these incorrect versions, it was possible to define a Parse Server dependency that pointed to these version tags, for example if you defined this dependency: ```js "parse-server": "[email protected]:parse-community/parse-server.git#4.9.3" ``` We have since deleted the incorrect version tags, but they may still show up in your personal fork on GitHub or locally. We do not know when these tags have been pushed to the Parse Server repository, but we first became aware of this issue on July 21, 2021. We are not aware of any malicious code or concerns related to privacy, security or legality (e.g. proprietary code). However, it has been reported that some functionality does not work as expected and the introduction of security vulnerabilities cannot be ruled out. You may be also affected if you used the Bitnami image for Parse Server. Bitnami picked up the incorrect version tag `4.9.3` and published a new Bitnami image for Parse Server. **If you are using any of the affected versions, we urgently recommend to upgrade to version `4.10.0`.** These are the incorrect tags: ``` 4.0.0-beta1 4.0.0-beta2 4.0.0-beta3 4.0.0-beta4 4.0.0-beta5 4.0.0-beta6 4.0.10 4.0.11 4.0.12 4.0.13 4.0.14 4.0.3 4.0.4 4.0.6 4.0.7 4.0.8 4.0.9 4.6.0 4.6.0-beta 4.7.0 4.8.0 4.8.1 4.8.2 4.8.3 4.8.4 4.8.5 4.9.0 4.9.1 4.9.2 4.9.3 ``` ### Patches Upgrade to version `4.10.0`. ### Workarounds Downgrade to version `4.5.2`. ### References n/a
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | parse-server (npm) | 4.0.0 to before 4.5.2 | 4.5.2 | Patch available | GHSA-593v-wcqx-hq2w |
| — | parse-server (npm) | 4.6.0 to before 4.10.0 | 4.10.0 | Patch available | GHSA-593v-wcqx-hq2w |
- parse-server (npm) Vendor— Affected 4.0.0 to before 4.5.2 Fixed in 4.5.2 Patch available GHSA-593v-wcqx-hq2w
- parse-server (npm) Vendor— Affected 4.6.0 to before 4.10.0 Fixed in 4.10.0 Patch available GHSA-593v-wcqx-hq2w
Remediation
- Fix · GHSA-593v-wcqx-hq2w parse-server (npm) Fixed in 4.5.2 Advisory →
- Fix · GHSA-593v-wcqx-hq2w parse-server (npm) Fixed in 4.10.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-593v-wcqx-hq2w
- 2026-11-02 CVSS score added · GHSA-593v-wcqx-hq2w
- 2026-11-02 Weakness changed · GHSA-593v-wcqx-hq2w
- 2026-11-02 2 new references · GHSA-593v-wcqx-hq2w
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences